Apt update error

When I run apt update I get the error below…
OS: Debian 11.2

Please your help.

Ign:8 https://mirror.mva-n.net/mariadb/repo/10.6/debian bullseye InRelease
Err:9 https://mirror.mva-n.net/mariadb/repo/10.6/debian bullseye Release
  404  Not Found [IP: 443]
Reading package lists... Done
E: The repository 'https://mirror.mva-n.net/mariadb/repo/10.6/debian bullseye Release' no longer has a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Maybe similar to E: The repository 'https://mirror.mva-n.net/mariadb/repo/10.4/ubuntu focal Release' no longer has a Release file

Uhm… :thinking:

https://mirror.mva-n.net/mariadb/repo/10.6/debian bullseye Release

10.6 = Debian Buster

… 10.6 is the mariadb version. There is no need to open a new thread, situation is still the same:


Just a quick observation … I was having problems with this on all servers still running on mariadb 10.4, but later versions seemed OK. I decided to go ahead and upgrade the DB with the hestia script, as I was planning to do that anyway, and the problem went away as soon as I was on 10.6.
I’m not suggesting that everyone do this, but as I was going to do it anyway, it solved the issue for me.
[Not that the failure to update was at all dangerous, just irritating.]

The issue with apt errors was related to a syncing issue between the repo we used and the source…

We will adjust the apt repo to https://github.com/hestiacp/hestiacp/commit/4f6ce61e2ec31a4ac5575e5d807cc7c4ddc09ccf

OK, fair enough. In which case, I should mention that the URL added to apt by the upgrade_mariadb.sh script is also
deb [arch=amd64] https://mirror.mva-n.net/mariadb/repo/10.6/ubuntu focal main
So you might want to include that in your patch too.

Good point

Problem solved. No errors.

$ apt update

Hit:1 http://security.debian.org bullseye-security InRelease
Hit:2 http://ftp.debian.org/debian bullseye InRelease
Hit:3 http://ftp.debian.org/debian bullseye-updates InRelease
Hit:4 https://packages.sury.org/apache2 bullseye InRelease
Hit:5 https://nginx.org/packages/mainline/debian bullseye InRelease
Hit:6 https://packages.sury.org/php bullseye InRelease
Hit:7 https://apt.hestiacp.com bullseye InRelease
Hit:8 https://mirror.mva-n.net/mariadb/repo/10.6/debian bullseye InRelease
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done

same here
Index of /mirror/mariadb.org/repo/10.5/ubuntu/ focal Release
404 Not Found [IP: 80]

depot includes no release datafile
an update could not be started securely out of such data origin (depot)

I assume you have used some translation software.

It should be fixed right now apt update should work If not:


Where mariadb_v = 10.x
And version = Debian or Ubuntu

1 Like

Thanks for you reply! Yes, it was a translation software: Me:) Only for information: The link you did send was 404 and the update possibility for mariadb did not wor for two further days. Today it runs! hopefully through.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.