Cannot Re-add a domain after deletion

Hey guys, I just installed hestiacp 1.3 and everything is going well. I restored user backups from vestacp and it all came through no problem. When I deleted one of the restored domains to re-add it I got an error “Error: php-fpm pool doesn’t exist add domain”. Do note this only affects domains that are deleted that were originally restored from vestacp. For example, if I delete then try to add an entire random domain that was not restored first from vestacp there is no issue.

I don’t know what to do anymore. Please help. Can anyone advise on some troubleshooting steps? even though adding the domain fails, it still creates the PHP-fpm conf file and the folder at /home/user/web/. This is so weird.


1 Like

Interesting issue, we do regularly test restoring from Vesta backups however we haven’t seen this behavior.

Did you find the cause of the problem? Or at least some relevant error messages?

To reproduce it on our side we would need access to a sanitized Vesta backup file, without sensible/confidential user data

I got the same problem after accidentally deleting a domain over ssh and then removed it in vesta cp and then readding gave me the same error. I worked around this by simply using an entire vps snapshot.