DNS Cluster stopped working

Hello my dear Hestians,

I started receiving emails ( 5 per minute ) saying that the synchronization was not working.

Since I couldn’t get it to work I deleted the remote dns host and then tried:

Create API key in slave server: v-generate-api-key

And then on the master server:

$HESTIA/bin/v-add-remote-dns-host slave.mydomain.com 8083 XXXXX_API_KEY_XXXXXX

I got this error:
/usr/local/hestia/func/remote.sh: line 42: return: Error:: numeric argument required
Error: api connection to slave.mydomain.com failed

But my input is exactly as it should according to the official documentation and according to the internal manual that I made when I first set this up.

Any ideas?

When did it started?

After an upgrade or ?

  1. Check Server settings I
  2. Try if you can connect via an example

Thank you very much @eris

I logged into the slave server and changed the login screen to the old version at 13:30 approx.

I see all services in green in the slave server and the dns zones have not been erased.

The logs say:

13:40:35 System System configuration value changed (Key: API_ALLOWED_IP, Value: ).
13:40:35 System System configuration value changed (Key: LOGIN_STYLE, Value: old).

13:40:35 System System configuration value changed (Key: POLICY_SYSTEM_HIDE_ADMIN, Value: no).

13:40:35 System System configuration value changed (Key: POLICY_USER_CHANGE_THEME, Value: yes).

13:40:34 System System configuration value changed (Key: POLICY_USER_VIEW_SUSPENDED, Value: ).

13:40:34 System System configuration value changed (Key: POLICY_USER_VIEW_LOGS, Value: yes).

13:40:34 System System configuration value changed (Key: POLICY_USER_EDIT_WEB_TEMPLATES, Value: yes).

13:37:20 System Rebuilt DNS domain (User: dns-cluster, Domain: xxxxxxxxxxxxxxxxx.com).

13:37:19 System Service restarted (Name: bind9).

I don’t understand that.

13:40:35 System System configuration value changed (Key: API_ALLOWED_IP, Value: ).

Is this the remote server?

Yes it is

Set the ip of the master then… We have limited access of the api by default only to “local” ip instead the currently full open. Normally it should contain an ip or “allow-all”

Sorry @eris but I don’t understand.
Where should I set up the IP of the master?

The v-generate-api-key doesn’t allow an IP parameter.

The error in the $HESTIA/bin/v-add-remote-dns-host slave.mydomain.com 8083 XXXXX_API_KEY_XXXXXX command looks like a parsing error of the /func/remote.sh to me

We have limited the access to the api via an “white list” as we felt was to insecure that hackers had an easy way to login into the system.

See Rest Api — Hestia Control Panel documentation

Our return value is current a string

And the software “thinks” that a number is coming back but recives an string and throws it number.

Thank you! It worked! I whitelisted the IP in the panel and everything went back to normal.