Error: Unable to connect to the Hestia APT repository

I was VestaCP user. While searching for VestaCP alternatives I found HestiaCP is so promising. So I tried to install it on my VPS but always failed. Have been trying to install HestiaCP for several hours and never able to make it work. Tried with Debian 9, Ubuntu 16.04 and Ubuntu 18.04, always give me “Error: Unable to connect to the Hestia APT repository

I’m on OVH SSD VPS 2 GB RAM and pretty sure my internet connection is stable.

Could you tell did I do something wrong?

Hi @rooted

I just have checked our repository, it is up and running without any issue.

Can you try the following command?

ping apt.hestiacp.com

It is working as I get below response

64 bytes from 104.28.20.51: icmp_seq=1 ttl=55 time=13.3 ms
64 bytes from 104.28.20.51: icmp_seq=2 ttl=55 time=13.3 ms
64 bytes from 104.28.20.51: icmp_seq=3 ttl=55 time=13.4 ms
64 bytes from 104.28.20.51: icmp_seq=4 ttl=55 time=13.4 ms
64 bytes from 104.28.20.51: icmp_seq=5 ttl=55 time=13.4 ms
64 bytes from 104.28.20.51: icmp_seq=7 ttl=55 time=13.4 ms

Hello,
your error was raised here:

I guess it could be a issue with ca-certs , let’s see if you can download the signing key manually:

wget “https://gpg.hestiacp.com/deb_signing.key” -O - 2>/dev/null

No issue here since I got nothing after entering below line.

Thats not good, it should have printed the signing key.

Drop the redirect to /dev/null and post the error:

wget "https://gpg.hestiacp.com/deb_signing.key" -O -

It gives me ERROR 403: Forbidden

[email protected]:~# wget "https://gpg.hestiacp.com/deb_signing.key" -O -
--2019-10-10 09:52:40--  https://gpg.hestiacp.com/deb_signing.key
Resolving gpg.hestiacp.com (gpg.hestiacp.com)... 104.28.20.51, 104.28.21.51, 2606:4700:30::681c:1433, ...
Connecting to gpg.hestiacp.com (gpg.hestiacp.com)|104.28.20.51|:443... connected.
HTTP request sent, awaiting response... 403 Forbidden
2019-10-10 09:52:41 ERROR 403: Forbidden.

Edit:
I tried to download the key manually from my browser and its working fine. Perhaps my VPS IP blocked by HestiaCP?

Our repository is protected by cloudflare, maybe they banned your ip. I’ll check if i can do something from our side.

Please help to sort out this issue. Or if you need my VPS IP address, I’ll be gladly to provide it.

Can you send me your ip to [email protected]?

I just sent you an email. Please check.

Really appreciate your help.

Can confirm that your ip was blocked by cloudflare, I added a firewall rule to allow it - hope this will work. Otherwise you would have to contact cloudflare and ask to whitelist/deblock your ip.

I just tried it and still giving me same message. I thought it would work at first.

Welcome to the Hestia Control Panel installer!

Please wait a moment while we update your system's repositories and
install any necessary dependencies required to proceed with the installation...

(*) Installing ntpdate...
(*) Installing dirmngr...
(*) Installing apt-transport-https...
Error: Unable to connect to the Hestia APT repository

I think I’m going to contact them now.

Thanks for your help

Hello! I have same problem! Can I sent you my ip to solve the problem?

Thanks !

Just attempted to install on a fresh OracleCoud Ubuntu instance and I get the error “Error: Unable to connect to the Hestia APT repository”. After reading through this issue here, the consensus seems to be a block by Cloudflare. Can someone help me resolve this before I just abandon this attempt to try Hestia.

Write an email with your public ip to [email protected]