Error update 1.3 HestiaCP

I just updated from Panel and it shows me the following error:

Internal Server Error
Oops! Something went wrong.

The server encountered an internal error or misconfiguration and was unable to complete your request.

The previous version worked perfectly for me, there is a way to update 1.30 manually.

The url where I get the error is the following:

I also encountered a similar error. I had to connect via SSH and perform an update there.

sudo apt update && sudo apt upgrade -y

I just updated via command line without issues.

Panel does 500 error only while the installer rebuilds and configures Hestia.

Debian 10


I waited,rebooted my vps but still.

@amit Did you run apt update && apt upgrade -y on commandline?

Yes it is.

There was an issue with one of the dependency packages, apt update && apt install --reinstall hestia-php should bring the package up to date and restore access to the Control Panel.


I still got issues. I never had any issue accessing the control panel, but all sites are down and showing the message: No input file specified.

I have 6 VPS with Ubuntu 20.04 and only the servers that had Hestia automatic updates = yes are broken. Servers that didn’t have Hestia automatic updates are still working.

I have tested apt update && apt install --reinstall hestia-php and rebuild all and rebuild web domains. But nothing works.

The only thing that works is to change Backend Template PHP-FPM to PHP-7_3. This makes the sites work again.

The only thing I have change from a standard installation of Hestia is the port to the control panel.

Any suggestions how to fix this?

Hi @Torkel

Did you have webalizer active on the domains which went down? This may be the source of issue - i suggest you to set the stats to awstats or none and press save.

No, stats are none on all domains. Could it be related to this issue: ?

No this is an visual “bug” only

What was the original template? (Default)

Yes, It was default.

Are you sure that webalizer wasnt enabled? It shows no by default, i just had exactly that case yesterday.

I don’t have webalizer as an option, only awstats or none.

I have the same problem, I opened a bug issue in github

When i do: v-list-sys-php

That cant be right, or?

@Torkel v-list-sys-php output is right. Also webalizer isnt listed anymore, because the support has been dropped - that’s why it doesnt appear in the list. If you have had enabled webalizer, it could produced a bug that you basicly just need to press on save to rebuild/disable webalizer. This was just what I observed on a system which I had access to it and noticed that bug.

1 Like

Oki, thanks!

I have tried: apt update && apt install --reinstall hestia

But it didn’t have any effect on the issue.

So you still have domains, that arent working? Could you go there to edit web and just hit save once? If it doesnt work, change stats to awstats and hit save.

Okay, that works! Changing from none to awstats then save and then changing back and save will make a site work again. Thanks!

Anyway to do this on many sites from code? I need to do this on over 200 sites.