FTP certificate

I’ve just installed and configured a VPS with HestiaCP and everything works like a charm, except for something small.

I’m using the latest version of HestiaCP and I’ve several users with a domain in each one of them: domainone.com, domaintwo.com, etc.

I’ve noticed that every single time that I connect to a FTP account in the server (ftp.domainone.com, ftp.domaintwo.com, etc.), Filezilla complains with the message “Hostname does not match certificate”.

Let’s Encrypt is enabled in all the domains.

Is there any way to fix this? I’ve tried to disable and re-enable SLL/Let’s Encrypt in the domains but does not seem to work.

If I create manually a new certificate in the host that includes all the domains the problem is fixed, but I presume there is another way to do this, since I would like to avoid to issue a new certificate every single time I add or remove a certificate.

Is there anything I’m missing?

Thank you in advance!

Use hostname.domain.com or just ignore the errror…

1 Like