Global SMTP relay : invalid username format

I want to send email from HestiaCP by “Postal Server” which is self hosted. Postal create user name in format “Org/Server” but hestiacp does not accept username in this format and give error “invalid username format” Any suggestion to fix this

Edit the /usr/local/hestia/conf/hestia.conf manually?

Thanks for quick help and I tried tried but it does not send email. I have tested postal smtp settings at SMTP Test Tool which works fine.

Hestia reuses a lot of checks for other functions and;

so a valid email or username as string is allowed.

How ever / and \ are not on that list and that why it is failing…

so the only solution is to add an extra check for only this case that allows /

I am looking in exim4 logs and found this error “a TLS session is required, but the server did not offer TLS support” Looking further in this

Is it possible that I can set relay server security to none for test purpose

Edit of /usr/local/hestia/conf/hestia.conf by user name worked for me and I also edit /etc/exim4/smtp_relay.conf with proper username

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.