Hestia self-signed certificate and unable to get issuer certificate error

I’ve tried to issue a LetsEncrypt certificate for an HestiaCP installation, but a self-signed certificate keeps showing up…
Looking up in the forum I found that in these cases the v-add-letsencrypt-host should be run, but also here an error shows up:

C = US, O = Internet Security Research Group, CN = ISRG Root X1
error 2 at 2 depth lookup: unable to get issuer certificate

Btw I’ve already assigned a DNS record (fully propagated) to the host I’m trying to setup.

Try to restart nginx

Is a “Known” bug that I forgot about

Created an issue:

Hi @eris

You marked this thread as solved, but which is the solution?!

Wait for the next release, the issue has been fixed. If you can’t wait, adapt the change above to your local file and run the command again.

Requesting an SSL should still work. The only issue it will also request an SSL certificate if it is is valid. It is caused by the changes LE made to their SSL certificates and that ssl was expired…

If v-add-letsencrypt-domain user hostname.com fails check in the log why it fails

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.