Hestiacp Not Saving Domain's Backend Template PHP-FPM

Hi,

I’m using HestiaCP on a Debian 10 server with Nginx + PHP-FPM.

While the domain’s Web TemplateNGINX is saving fine, the Backend Template PHP-FPM doesn’t save and always loads the “default” template.

This template seems to be overridden on panel updates (or periodically, since my changes made to it keep disappearing). This results in getting some of my websites unreachable that require a particular “open_basedir” path.

The best approach is to make my own templates as I did for the Nginx web templates. However, since the Backend PHP-FPM template is not saving, I don’t know what other options I have.

Is this a known bug or something that has to do with my configuration?

Thanks!

There is already a open issue report on github, we currently review it and working on fix: https://github.com/hestiacp/hestiacp/issues/1020

Thank you very much for letting me know this is a confirmed bug and there’s already a fix in the working. :wave:

1 Like

I’ve cacth the same issue today.

I have a similar problem:
In the /etc/php/7.4/fpm/pool.d folder, edit the domain.conf
I put pm.max_children = 24, but after a while pm.max_children = 8, or again by default.
Did not update the system, it turns out that when you restart pm.max_children = by default!? And the site crashes because of pm.max_children.
And how to be here !?

During update of the system it resets to its default. See error message

https://docs.hestiacp.com/admin_docs/web.html#how-can-i-change-settings-for-a-specific-domain

Create a new template to prevent such thing …

A simple solution ! Now, just edited the template, put:
pm.max_children = 24
pm.max_requests = 5000

Don’t update the default templates create a new one !

2 Likes