Hestiacp on Proxmox VM

Having a hell of a job trying to get Hestiacp installed in a proxmox VM.

the installer is hanging on

Installation backup directory: /root/hst_install_backups/250620211254
Installation log file: /root/hst_install_backups/hst_install-250620211254.log

Adding required repositories to proceed with installation:

[ * ] NGINX
[ * ] PHP
[ * ] Apache2
[ * ] MariaDB


Reading package lists...
Building dependency tree...
Reading state information...
wget is already the newest version (1.20.3-1ubuntu1).
wget set to manually installed.
ca-certificates is already the newest version (20210119~20.04.1).
ca-certificates set to manually installed.
curl is already the newest version (7.68.0-1ubuntu2.5).
curl set to manually installed.
dirmngr is already the newest version (2.2.19-3ubuntu2.1).
dirmngr set to manually installed.
gnupg is already the newest version (2.2.19-3ubuntu2.1).
gnupg set to manually installed.
software-properties-common is already the newest version (
software-properties-common set to manually installed.
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,704 B of archives.
After this operation, 161 kB of additional disk space will be used.
Get:1 http://gb.archive.ubuntu.com/ubuntu focal-updates/universe amd64 apt-transport-https all 2.0.5 [1,704 B]
Fetched 1,704 B in 0s (30.7 kB/s)
Selecting previously unselected package apt-transport-https.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 71441 files and directories currently installed.)
Preparing to unpack .../apt-transport-https_2.0.5_all.deb ...
Unpacking apt-transport-https (2.0.5) ...
Setting up apt-transport-https (2.0.5) ...

The error is Updating currently installed packages, please wait… W: GPG error: https://mirror.mva-n.net/mariadb/repo/10.5/ubuntu focal InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY F1656F24C74CD1D8
E: The repository ‘https://mirror.mva-n.net/mariadb/repo/10.5/ubuntu focal InRelease’ is not signed.

can you help please

I have no issues with installing Ubuntu / Debain VM running PROXMOX.

apt-key adv –keyserver keyserver.ubuntu.com –recv-keys F1656F24C74CD1D8
sudo apt-get update


sudo gpg --keyserver pgpkeys.mit.edu --recv-key F1656F24C74CD1D8
sudo gpg -a --export F1656F24C74CD1D8 | sudo apt-key add -
sudo apt-get update

Neither worked still hangs on the same
if I ctrl + c it continues to install

I have tried on debain 10 and ubuntu 20.04.2 (closes I could het to the 20.04 on there website) with the same errors.

will have to try PostgreSQL and see if that works out of the box.

Thank you for helping… :slight_smile: appreciated

Try a different mirror?

Tired a different mirror and with PostgreSQL and same error…

if I ctrl + c in terminal it seems to continue with the install and lets me in the panel… will keep playing around with it and see what I come up with…

Thank you once again