How to install certain or uninstall unwanted PHP version for MultiPHP?

Is there anyway pick and choose the PHP version (e.g. only 5.6 & 7.4) for Multiphp?


v-add-web-php 5.6
v-add-web-php 7.4 (Enabled by default since 1.3.0)


Thanks eris, as in perform default installation (no --multiphp) and run v-add-web-php 7.4 after installation?

Yes but run v-add-web-php 5.6.

By default 7.4 is always already installed / availble


Thanks @eris is there anyway to perform the opposite to remove installed one?



It’s a quit good topic for my problem !

I moved all domains to PHP 7.4. Everything was working great.

I was asking myself how to remove unneeded PHP versions. I found v-delete-web-php and used it to delete PHP7.3.

Unfortunately I was not told this was the system’s main PHP version. So now roundcube doesn’t work anymore. The reason is the pdo_mysql modul is not anymore there. I was wondering what it should mean ?

Well, v-delete-web-php deleted all modules (/etc/php7.3), but not all php7.3 stuff. And it seems that roundcube itself looks for pdo_mysql of the system’s main PHP version instead of the PHP used by the domains… Is it a bug ? Or just my missunderstanding how to use it ?

Meanwhile I set PHP7.4 as system’s main version, but roundcube still doesn’t work saying me:
PHP Fatal error: Uncaught Error: Class 'PDO' not found in /usr/share/roundcube/program/lib/Roundcube/rcube_db_mysql.php:144

php -i shows that all is fine with the pdo_mysql modul: enabled etc.

I checked the roundcube settings regarding apache and php but I was not able to find the source of my problem.

Have you any idea ? How to reinstall PHP7.3 ? Kindly note: v-add-web-php 7.3 doNOT work ! Whatever it does, it doesn’t bring me php 7.3 back…

Thank you and best regards !

Is it possible to run php7.4-frm for “domain1” and php8.0-frm for “domain2” using one user account in CP? I set this options for two domains, made a p.php (phpinfo():wink: page and they show as I nedded different php-versions for the domains: one runs at 7.4, another 8.0
But using bash#top I see php-fpm7.4 running only when browsing domain2 that supposed to use 8.0
Do I need to make some more changes?

SOLVED! Restarted apache2 and both php7.4 | php8.0 are shown via bash#top =) many thanks vor HiestiaCP

Yes it should work fine

1 Like