Http-to-https not working for some domains


I use hestia since a while for my server, and serve some domaines with it.
I don’t understand why, but on one of my domains (, the http-to-https redirection is not working.
I’ve tried to disable, save, enable it, but it didn’t changed.
Also even tried to delete the domain on hestia panel, re-create it without ssl, then enable SSL (LE) and http-to-https, but still no luck :frowning: :thinking:

Do you have any advice to give me ?


sounds weird - have you checked, that it’s not a caching issue with the browser?

also try to manually restart nginx from cli, to see if there is something wrong with the config - which prevents it from restarting and loading the new config at all.

as nginx is taking part of that redirect, you could check the config file inside /home//conf/web/

You were right : nginx did not restart when I tried to restart it from command line . There was a duplicate “error” location in one of the conf files, so I assume it was not restarting…

Now it works :wink: Thanks !