Internal Server Error when exim4 is disabled

Hello, wonderful community of HestiaCP!

The installation was done by my hoster, they have it pre-installed, so I can’t exclude exim4 in advance.
I think this is a mistake, because if exim4 was needed once and now it is not used and needs to be disabled, and this breaks HestiaCP.
I ran into an error when disabling everything extra, found on the forum HestiaCP disabling exim4 like this.

sudo systemctl stop exim4;
sudo systemctl disable exim4;
nano /usr/local/hestia/conf/hestia.conf


It is after this disconnection, or rather, after its removal of the variable value, that the service can work, but if you remove MAIL_SYSTEM=‘’ from the variable, in this case, after any saving of settings, an internal server error 500 is returned, redirecting to page 500 from HestiaCP.

How can this be fixed?

What is the error in /var/log/hestia/nginx-error.log?

Hid the data at the end

client: (My IP was here.)


host: “Here was my Hostname”

[error] 617#0: *6 FastCGI sent in stderr: "PHP message: PHP Warning:  Undefined array key "v_php_versions" in /usr/local/hestia/web/edit/server/index.php on line 291; PHP message: PHP Warning:  Undefined array key "v_debug_mode" in /usr/local/hestia/web/edit/server/index.php on line 410; PHP message: PHP Warning:  Undefined array key "v_webmail_alias" in /usr/local/hestia/web/edit/server/index.php on line 598; PHP message: PHP Warning:  Undefined array key "v_webmail_alias" in /usr/local/hestia/web/edit/server/index.php on line 600; PHP message: PHP Fatal error:  Uncaught TypeError: Hestiacp\quoteshellarg\quoteshellarg(): Argument #1 ($arg) must be of type string, null given, called in /usr/local/hestia/web/edit/server/index.php on line 600 and defined in /usr/local/hestia/web/inc/vendor/hestiacp/phpquoteshellarg/src/Hestiacp/quoteshellarg/quoteshellarg.php:14
Stack trace:
#0 /usr/local/hestia/web/edit/server/index.php(600): Hestiacp\quoteshellarg\quoteshellarg()
#1 {main}
  thrown in /usr/local/hestia/web/inc/vendor/hestiacp/phpquoteshellarg/src/Hestiacp/quoteshellarg/quoteshellarg.php on line 14" while reading response header from upstream, client: MY_IP, server: _, request: "POST /edit/server/ HTTP/2.0", upstream: "fastcgi://unix:/run/hestia-php.sock:", host: "MY_HOSTNAME:8083", 

This is the last entry I reproduced the error again and this error immediately occurred.
There are other errors if you need to, let me know they are not many as the install is clean.

Please help) I will be very grateful, besides, the mistake is unpleasant

The issue should be fixed if you install 1.8.4


Yeah that worked out great!
You are the best, thank you, for your work!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.