Letsencrypt host error

Hi guys maybe you can help with this little issue.

I ran v-add-letsencrypt-host and I get 400 error.

So I went to https://letsdebug.net/ to find the problem that its having and I got:



No valid A or AAAA records could be ultimately resolved for panel.eve-lbs-studio.co.uk. This means that Let's Encrypt would not be able to to connect to your domain to perform HTTP validation, since it would not know where to connect to.

No A or AAAA records found.

So after that I tried adding a DNS Zone in the dns section of the panel for panel.eve-lbs-studio.co.uk and I got the error:

Error: Web domain eve-lbs-studio.co.uk exists

I get the same error when trying to add a dns zone via command line.

I should probably add that there is no domain or dns record that has panel.eve-lbs-studio.co.uk apart from the domain in the admin account (no dns was created by default for the domain upon installation).

Does the domain:
eve-lbs-studio.co.uk exists?


Thank you eris that sounds like that is the issue, didnt see that in the docs, will have a go soon currently nowhere near my pc …

Yhank you

It is related to an security “bug”

It would be a bad idea to allow user A create webmail.userb.com and then again access to the email accounts with a spoofing method

its a private server for personal use.

I thought I would also mention that the command “v-delete-web-domain-allow-users user domain.com” didn’t work so I reinstalled from a snapshot and unchecked the option Enforce subdomain ownership in the configure server page and that worked.

I set the admin user to only access via local IP, its only me using the panel on my small home server mainly for learning purposes but I do host a couple of my websites on it. :slight_smile:

In the settings there is an “option” disable enforce domain owner ship

Disable it and it will work as intented

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.