Mail SSL Hostname Problem


I’ve got the following problem, when I add an email in my mail program (tried several ones) I get the following error:

It shows the hostname certificate instead of the certificate (which does exist tho). If I accept using the hostname certificate, mails are landing in the spam folder of recipients. If I insert the hostname as mail server in the email program instead of mails don’t land in the spam folder of recipients and everything works fine.

I’ve made a fresh installation of hestiacp 1.4.7 on clean debian 10 minimal and only ran this command: v-add-letsencrypt-host

Any regards on how to resolve this issue?

Edit the mail domain and enable ssl over letsencrypt.

1 Like

Thanks for your answer!

I already had SSL enabled for the domain. I disabled and re-enabled it, getting a nginx restart error because of missing SSL cert files for the domain. I was stuck there also getting this error using the CLI:

v-add-letsencrypt-domain username '' yes
Error: nginx restart failed

Strangely, it was possible to get around this by suspending and unsuspending the mail domain:

v-suspend-mail-domain username
v-unsuspend-mail-domain username

then successfully running the lets encrypt command for the mail domain afterwards:

v-add-letsencrypt-domain username '' yes

After that, the mail seems to work properly, but unfortunately webmail didn’t work (showed only success page) it was set to roundcube in admin panel and disabling and re-enabling it over the admin panel didn’t resolve the problem.

By running the CLI for some reason it worked

v-add-mail-domain-webmail username roundcube yes

When nginx is not restarting, try nginx -t

When nginx does not restart nginx -t and see why.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.