Nginx authentication

Hello I installed today hestiacp with nginx without apache, so far all good.

i wanted to backup my phpmyadmin via passwd. but somehow it does not grab.

i edited the file nginx.conf as follows:
location /phpmyadmin/ {
auth_basic “Restricted Content”;
auth_basic_user_file /path/to/hestia.passwd;
expires off;
index index.php;
Nginx restart
server restart

everything does not work

as far as I remember there is a separate include file for the phpmyadmin configuration which most likely overrides your settings or even leads to a conflict because of the same location block.

also be aware that some of the config files could be overwritten by future updates, though this mostly only affects the domain related confs based on the templates.

Did you find
/etc/nginx/conf.d/ (should be conf?)

I’m using apache+nginx setup, so I can’t try it out for you, but I’m guessing that would be where to look. Also as falzo mentions, that will probably be overwritten, so bear that in mind. You may be able to figure something out dumping your own
file into that directory, which wouldn’t get overwritten.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.