Roundcube not working, error 500

Can you please tell me in which configuration files there may be an error? or maybe there is a command how to set the default configuration.
Roundcube not working, error 500.
This is what I am see in the logs:

[Fri Feb 04 10:50:32.696417 2022] [php7:warn] [pid 80198] [client 79.184.1.139:0] PHP Warning:  Unknown: failed to open stream: Operation not permitted in Unknown on line 0
[Fri Feb 04 10:50:32.696427 2022] [php7:error] [pid 80198] [client 79.184.1.139:0] PHP Fatal error:  Unknown: Failed opening required '/var/lib/roundcube/index.php' (include_path='.:/usr/share/php') in Unknown on line 0

Maybe there is some command that will reinstall the system while saving the data.
I have tried this command.
apt update && apt install --reinstall hestia

Thanks a lot for any idea.

Does the file:

/var/lib/roundcube/index.php

exists?

1 Like

Yes:

[email protected]:~# ls -la /var/lib/roundcube/index.php
-rw-r--r-- 1 root www-data 11413 Dec 29 22:29 /var/lib/roundcube/index.php

v-add-sys-roundcube should ussally work.

But root www-data is the correct permission…

1 Like

I have tried this command:

[email protected]:~# v-add-sys-roundcube
Error: Installed version (1.5.2) is equal to the available version (1.5.2)

Ok, all is good problem been on hestiacp settings → apache2 → Settings php → more settings
and in config been wrong line:

open_basedir = ""

Change on:

;open_basedir = ""

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.