Sudden change os SSL

Hi.

Been reading around to try to find the same issue issue but no luck.

My SSL for panel.domain.ltd does not work for a random reason.

I have not changed any dns settings.

Server hosted remotely. Hostname and reverse dns on host are both panel.domain.ltd. the domain are directed to the rigth IP.

I have tried to issue the SSL cert on the server again. Rebooted the server.

All 8 domains hosted on the server have no issues with the SSL on their end. only my panel/server SSL.

Any ideas on where to start next?

Hi @Hawolex,

The certificate is showing the right data?

openssl x509 -noout -in /usr/local/hestia/ssl/certificate.crt -issuer -dates -subject -ext subjectAltName

If it is not showing the right data for your hostname, try to issue a new certificate:

v-add-letsencrypt-host
issuer=C = US, ST = California, L = San Francisco, O = MyCompany Inc., OU = IT, CN = panel.domain.ltd
notBefore=Jan  2 20:27:01 2024 GMT
notAfter=Jan  1 20:27:01 2025 GMT
subject=C = US, ST = California, L = San Francisco, O = MyCompany Inc., OU = IT, CN = panel.domain.ltd
No extensions in certificate

Hostname seems ok here yes.

That’s a self signed certificate that your browser will show as invalid.

Use v-add-letsencrypt-host to add a Let’s Encrypt certificate for your hostname.

Unable to add panel.domain.ltd. domain.ltd belongs to a different user
This when i do as root in CLI

v-change-sys-config-value ENFORCE_SUBDOMAIN_OWNERSHIP no

And try again:

v-add-letsencrypt-host
2 Likes

Thanks for fast and super help. SSL are new grounds for me. It solved the issue for me atleast :smiley:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.