Trouble Setting Up Hestia CP

All ok… and this log?

tail -n20 /var/log/apache2/domains/webmail.asmt.edu.np.log
2 Likes
root@src:~# tail -n20 /var/log/apache2/domains/webmail.asmt.edu.np.log
tail: cannot open '/var/log/apache2/domains/webmail.asmt.edu.np.log' for reading: No such file or directory

2 Likes

I would need to access your server and see what’s going on… I’ll send you a private message.

2 Likes

The issue is solved.

Just for the records.

Checking /var/log/roundcube/error.log I could see this error message:

[15-May-2024 15:45:24 +0545]: <ubhl6ep8> DB Error: SQLSTATE[HY000] [1045] Access denied for user 'roundcube'@'localhost' (using password: YES) in /var/lib/roundcube/program/lib/Roundcube/rcube_db.php on line 201 (HEAD /)

So the user roundcube can’t access to the DB… strange.

I extracted the password used by roundcube:

# grep db_dsnw /etc/roundcube/config.inc.php 
$config["db_dsnw"] = "mysql://roundcube:S3cretP4ss@localhost/roundcube";

And tried to login manually:

# mysql -uroundcube -p
Enter password: S3cretP4ss
ERROR 1045 (28000): Access denied for user 'roundcube'@'localhost' (using password: YES)

So, the pass is not the right one so I changed it:

mysql -uroot -e 'ALTER USER 'roundcube'@'localhost' IDENTIFIED BY "S3cretP4ss";'
mysql -uroot -e 'FLUSH PRIVILEGES;'

And now roundcube user can login and webmail is working fine.

Due the webmail wasn’t working (perms bug) @sed executed the script /usr/local/hestia/install/upgrade/manual/migrate_roundcube.sh and this script modified the roundcube password in DB but the script didn’t modify the password in /etc/roundcube/config.inc.php and that was the reason for the error.

That’s all :wink:

2 Likes