Update from v1.0 to latest version


My current version is 1.00.0 Release 190618, how to update to latest version without loosing all data?

I’ve tried update from panel, installed new key, and everything - but it just ignores everything.

Thanks a lot

What happens on a apt update && apt upgrade?

Here is full output: https://pastebin.com/raw/FvYXy27Z


I also tried to use “apt-get upgrade hestia*” and output is:
hestia is already the newest version (1.00.0-190618).

Looks like you removed the hestia apt repository, that’s why it doesnt find any new package. Check if /etc/apt/sources.list.d/list.conf exists, if not, you need to add it again:

echo "deb https://apt.hestiacp.com/ CODENAME main" > /etc/apt/sources.list.d/hestia.list

Replace codename with your system codename like “buster” or “bionic”. Then run again apt update && apt upgrade.

Okay, list.conf was empty - strange.

Upgrade to latest version done without any issues, everything seems functioning!



Ok there is some issue with LetsEncrypt, I get this error when I try to activate it for domain:

Error code: 15

Any ideas? Thanks

I also got this error:
Error: Let’s Encrypt validation status 400. Details: (without details)

About error code 15, according to the list its a connection failed:

0 OK Command has been successfuly performed
1 E_ARGS Not enough arguments provided
2 E_INVALID Object or argument is not valid
3 E_NOTEXIST Object doesn’t exist
4 E_EXISTS Object already exists
5 E_SUSPENDED Object is suspended
6 E_UNSUSPENDED Object is already unsuspended
7 E_INUSE Object can’t be deleted because is used by the other object
8 E_LIMIT Object cannot be created because of hosting package limits
9 E_PASSWORD Wrong password
10 E_FORBIDEN Object cannot be accessed be the user
11 E_DISABLED Subsystem is disabled
12 E_PARSING Configuration is broken
13 E_DISK Not enough disk space to complete the action
14 E_LA Server is to busy to complete the action
15 E_CONNECT Connection failed. Host is unreachable
16 E_FTP FTP server is not responding
17 E_DB Database server is not responding
18 E_RRD RRDtool failed to update the database
19 E_UPDATE Update operation failed
20 E_RESTART Service restart failed

For this you need to check the logs and describe, where exacty the issue occures.

For le error 400, checkout the forum, there are already a lot of entries about this issue and possible fixes: https://forum.hestiacp.com/search?q=400