Zlib decompression failed with mod_curl

I have Ubuntu 20.04 and Hestia. PHP (7.2 and 8.2 too) is getting error from mod_curl

Unrecognized content encoding type. libcurl understands identity content encodings.

With request

GET /url HTTP/1.0
Host: www.domain.com
Accept: text/html,application/xhtml+xml,application/xml,application/json;q=0.9,image/webp,*/*;q=0.8
User-agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.117 Safari/537.36
Accept-encoding: gzip
Accept-language: ru-RU,ru;q=0.8,en-US;q=0.6,en;q=0.4
Connection: close

This is definetly not a problem of remote server - a bunch of urls of different hosts do fail that way. (but another bunch of URL worked in the same time! And it’s irrelevant of http/https)

When I run command line
curl -v http://domain.com
it’s getting ok.

I updated libcurl and
sudo apt update && sudo apt upgrade

but that not helped. If I remove “Accept-encoding” header - everything’s ok. But I’m can’t patch all packets, after all, it could be composer etc and many of them in dependencies…

Any help will be appreciated.