Add third part service on specific port

Hello! I’m new on hestia and on service management.
I’m trying to use hestia to simplify this task and it works very well, I’ve my domain on my VPS and all seems ok.

I need to install a third part service, metabase, but when I start it nothing happens on the specific port, 3000.
So I did some test in local environment (windows as host with virtualbox, running ubuntu server 22.03 as guest).

  1. installed ubuntu server 22.03 on virtualbox
  2. installed openjdk-11-jdk
  3. downloaded metabase.jar from and start it with java -jar metabase.jar
  4. forwarded port 3000 from guest to host
  5. I can access to metabase web gui at localhost:3000 from my host and that’s what I expected
  6. installed hestia on default port 8083 and restart the virtual machine
  7. forwarded port 8083 from guest to host
  8. I can access to hestia web gui at localhost:8083 from my host
  9. restart metabase with java -jar metabase.jar
  10. can’t access to metabase gui at localhost:3000

I think I miss some configuration on nginx, can anyone help me?

You must add a firewall rule to allow connections to port 3000 or add a new web domain with a web template that proxy pass requests to your metabase app.

Edit: forgot to add the link to Hestia doc to add a new firewall rule:

Also, for the template option, you could use the forgejo template for Nginx to test your application, it proxy pass to localhost 3000 so it should work fine for your use case…

1 Like

Thanks for the response!
I’ve used the firewall and it works!
I’m studying the web template solution.

I think I can close the thread.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.