After installing Hestia 1.8.11 in Ubuntu 22.04, the roundcube cannot be opened

After installing Hestia 1.8.11 with Ubuntu 22.04 yesterday,
Unable to open the roundcube by entering webmail. domain. ltd
The webpage displays: “Oops… something wet wrong!”!
An internal error has occurred Your request cannot be processed at this time
“For administrators: Please check the application and/or server error logs for more information.”
Just a few days ago, I installed Hestia (not 1.8.11) on another VPS using Ubuntu 22.04 and it was still working fine. The roundcube can still be used normally (but the system hosts file does not include this: 127.0.0.1 localhost).
May I ask if this is a bug in version 1.8.11? How to fix it? So that I can use the roundcube?
Thank u!

Change permissions to php files in /etc/roundcube/

find /etc/roundcube/ -type f -iname "*php" -exec chmod 644 {} \;

Once done, try to access webmail.

Edit: As there are passwords inside config files, this should be a better approach to fix the issue:

chown -R hestiamail:hestiamail /etc/roundcube/
find /etc/roundcube/ -type f -iname "*php" -exec chmod 640 {} \;
2 Likes

Thank you my friend!
Now I can enter roundcube.
When someone send mail to me, I could get the mail in roundcube.
But when I send mail in Roundcube, it says “SMTP error. Authorization failed”, and I can’t send mail.(I have never encountered this error before when using roundcube)
Could you tell me how to fix it?Thank you.

I suppose the error message is actually “Authentication failed”.

Did you add a valid certificate to your mail domain?

Show the output of (if you get command not found, install telnet: apt install telnet):

telnet localhost 587

Edit: I wrote telnel instead of telnet so I fixed it.

Also, show the output of this command (if you don’t get an output, it’s good, if you receive 127.255.255.254 then there is a problem):

dig 1.1.1.1.zen.spamhaus.org +nodnssec +short

thanks sahsanu.
I haven’t add a valid certificate to my mail domain.


I guess SSL was not used for email transmission.

I executed the command: telnet localhost 587; The result is as shown in the picture.
WX20231201-164429

I also executed the command: dig 1.1.1.1. zen. spamhaus. org+nodnssac+short
The result has no output.
Now, my friend, what should I do?

Add it and try again.

As a supplement, Without SSL certificate,I used the “Mail” app on my MacBook Air and successfully sent/received emails using my email account on the email server.


Now I have added an SSL certificate to the domain name.
Failed to add self signed certificate in the panel.
Adding certificates for Let’s Encrypt also failed.

How are you connecting to your server with that mail client? I mean, which port if you are using ssl or tls, etc.

What that means? What is the error?

Show the output of:

ls -l /home/admin/conf/mail/i188i.com/

If exists, show the contents of file nginx.conf_letsencrypt:

cat /home/admin/conf/mail/i188i.com/nginx.conf_letsencrypt

The email app on MacBook does not display port information, only username and password.
I have set up a proxy email account on the email website mail.qq.com, which displays the account information as shown in the picture. It appears that ports 110 and 587 are being used.

I can successfully send/receive letters using my email account on the mail.qq.com website
That is to say, currently only in the roundcube can emails be sent (but can be received)

WX20231201-181638
When adding a self signed certificate, this error is displayed

WX20231201-182108

To summarize, using a third-party email client can successfully send and receive emails. Using roundcube can only receive emails, not send them
I personally feel that it has nothing to do with whether SSL is enabled for email transfer. I wonder if my guess is correct?

I don’t know what the root cause is so I’m trying to rule things out and the fact that you can’t issue a Let’s Encrypt cert worries me.

If you try to use this command:

curl -IkL http://mail.i188i.com/.well-known/acme-challenge/test

You should receive a 200 response from nginx instead of 404 so something is not working properly.

Rebuild your mail domain and try to get a cert again.

v-rebuild-mail-domain admin i188i.com
v-add-letsencrypt-domain admin i188i.com '' yes

If that doesn’t work, let’s try to connect to smtp using port 25.

Backup roundcube conf file:

cp -p /etc/roundcube/config.inc.php /root/

Edit /etc/roundcube/config.inc.php file and remove these lines:

 $config['smtp_conn_options'] = array(
   'ssl'         => array(
     'verify_peer'  => true,
     'verify_depth' => 3,
     'cafile'       => '/etc/openssl/certs/ca.crt',
   ),
 );

and replace

$config["smtp_host"] = "localhost:587";

by

$config["smtp_host"] = "localhost:25";

Save the file, close your browser, start your browser, try to connect to webmail again and send a mail.

If that doesn’t work… I’m running out of ideas…

I have edited /etc/roundcube/config.inc.php file.

but it is no useful…

I will reinstall ubuntu22.04 and try agian。

If the bug still exists, then I can only wait for the next version to take a look.

Anyway, thank you!

Although it is not possible to send emails on roundcube, at least third-party client software can be used to send emails…

The upgrade to HestiaCP 1.8.11 generated a severe problem with the mail server. I am unable to set up webmail for new domains or enable Let’s Encrypt SSL for webmail (as indicated in #8).

It seems that we can only wait for the new version to solve the problem

Error:
“Oops… something wet wrong!”!
An internal error has occurred Your request cannot be processed at this time
“For administrators: Please check the application and/or server error logs for more information.”

ls -la /etc/roundcube/
sudo drwxr-x–x 3 root hestiamail 4096 Dec 7 15:02 roundcube

corregir usar
sudo chown -R root:www-data /etc/roundcube/

This works for me!!! Many thanks!

this worked for me. now i can access webmail. thanks

Hestia 1.8.11
Debian 12

1 Like