After VM restart the Hestia CP login always redirect back to login

Everything worked great for months

but today after I have rebooted the VM few times ( I use Hestia CP to develop locally) the login no longer works.

After login details entered it would always go back to login.

I believe the Database is not working either as my App is unable to connect too.

I am not sure what logs to even look at as why it would just break like that after VM restart.

Maybe cookie related.

or disk full, also check auth logs in /var/log/hestia

Hi before we jump into any crazy theory it was like it worked. I have rebooted local VM and the I could no longer login.

That was first thing that I have tried, removing cookies as well as using private browser window

I do only mount project files and not writing onto a VM
Here is the free space:
Filesystem Size Used Avail Use% Mounted on
udev 732M 0 732M 0% /dev
tmpfs 156M 1.2M 155M 1% /run
/dev/mapper/ubuntu–vg-ubuntu–lv 6.6G 6.5G 0 100% /
tmpfs 779M 0 779M 0% /dev/shm
tmpfs 5.3M 0 5.3M 0% /run/lock
tmpfs 779M 0 779M 0% /sys/fs/cgroup
/dev/sda2 1.9G 215M 1.5G 13% /boot
/dev/loop1 67M 67M 0 100% /snap/core20/1738
/dev/loop0 67M 67M 0 100% /snap/core20/1695
/dev/loop2 97M 97M 0 100% /snap/lxd/24061
/dev/loop3 53M 53M 0 100% /snap/snapd/17883
/dev/loop4 97M 97M 0 100% /snap/lxd/23991
backend 501G 149G 352G 30% /home/admin/web/
tmpfs 156M 0 156M 0% /run/user/1001

only last successful login was before it worked

error.log - seems to be spammed with db errors
2022-12-11 15:27:08 v-add-user-sftp-jail ‘syslog’ ‘no’ [Error 3]
2022-12-11 15:27:08 v-add-user-sftp-jail ‘syslog’ ‘no’ [Error 3]
2022-12-11 17:52:44 v-add-user-sftp-jail ‘syslog’ ‘no’ [Error 3]
2022-12-11 17:52:44 v-add-user-sftp-jail ‘syslog’ ‘no’ [Error 3]
2022-12-11 17:54:55 v-add-user-sftp-jail ‘syslog’ ‘no’ [Error 3]
2022-12-11 17:54:55 v-add-user-sftp-jail ‘syslog’ ‘no’ [Error 3]
2022-12-11 17:55:01 v-update-sys-rrd-mysql ‘daily’ [Error 15]
2022-12-11 18:00:02 v-update-sys-rrd-mysql ‘daily’ [Error 15]
2022-12-11 18:05:02 v-update-sys-rrd-mysql ‘daily’ [Error 15]

/dev/mapper/ubuntu–vg-ubuntu–lv 6.6G 6.5G 0 100% /

This might be the issue

No disk space left

1 Like

and u dont think that your root is full? :slight_smile:

edit: havnt noticed jaaps post, but it is the source for sure.

1 Like

Thanks for that. I never had issues with default Ubuntu install as I used version before v18.
The current Hestia CP used Ubuntu 22.04

Apparently, the issue like you say is the no space for root that is caused by stupid Ubuntu bug: bad default space partitioning that existed since Ubuntu 18.04 all the way to Ubuntu 22.04

I will attempt to fix it tomorrow and see if that fixes the issue.

Check /var/log/ folder and check if can clear somethings…

Thanks everyone for help!

It was a space related issue due to some weird setup on Ubuntu LVM and Virtual Box specific solution of how to make partition larger.

TL;DR make sure that you Ubuntu VM is larger than 10 GB as you run out of space just from installing basics

best visual guide of how to fix VM disk issues I followed this guide:
[,”%20when%20you’re%20done.](https://How to resize VM drive)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.