Afterlogic returns 404


I am trying to manually install the afterlogic mail client on Ubuntu 20.04 (x86_64) using this instructions: Other Webmail Clients - #4 by eris

Afterlogic is located here: /var/lib/afterlogic

But when I run http://XX.XXX.XX.XX/afterlogic/adminpanel to configure it, then I got the following error:

Page Not Found

Oops! We couldn’t find the page that you’re looking for.
Please check the address and try again.
Error Code: 404

Any ideas how to fix it? Thank you.

You probably didn’t follow all the instruction and you are missing multiple config files and so on…

Ok. I will check it again. Thanks.


I would like to know what apache/nginx config files Hestia changes during the installation on the Ubuntu server? How it makes the server to load it from https://WEBSERVER_IP:PORT/login/? Thank you.

Look at GitHub - hestiacp/hestiacp: Hestia Control Panel | A lightweight and powerful control panel for the modern web.

For Hestia we use our own Nginx server that can’t be changed also it is missing a lot of critical php modules like mysql and so on.

As we don’t support any other webmail clients except Roudcube / Rainloop you have to sort out your self. I am not going to invest time for free for something that Hestia doesn’t use …

I can fix this issue by myself. My question is only about Hestia since I do not want to open another thread here. From what conf file location the server actually loads Hestia configurations?
As you can see there are a lot of them. Thanks.



Where hestia.conf where the Hestia loads config from.

1 Like

Good. Thank you.


I would like to know where exactly HestiaCP sets this path: /var/www/html

So, when I run http://XX.XXX.XX.XX/ it displays index.html with the following content:

What HestiaCP config file contains such info? Thank you.

As told we use highly costumized set up /var/www/html is only when a site doesn’t exits. And should not use PHP

Check the config files in /etc/nginx
/etc/apache2 and so on.

As told we don’t support it out of the box and you sort it out your self…

I have verified that those files does not contain such path: /var/www/html. It must be somewhere else. You as developer must know what your program stores and where it is located.


I am asking questions only about Hestia configuration files. As I said early, I will fix this issue by myself and do not need any help. I think this forum is for Hestia users or not?

You got the answer, check the content of /etc/apache2, there you’ll find a conf with IP.conf in conf.d subfolder which points to /var/www/html - you can adjust that specific config, but not sure at all if they got overwritten.

1 Like

I have fixed this Afterlogic issue.


  1. Create the afterlogic directory here: /var/www/html/, so the path will be: /var/www/html/afterlogic;
  2. Navigate to this directory and unzip the content of the afterlogic archive to this directory: unzip;
  3. Open the browser and navigate to: http://XX.XXX.XX.XX/afterlogic/, you will get 500 error.
  4. Navigate to /var/www/html/afterlogic and remove the .htaccess file. This file is not required, since the /data directory is protected by another .htaccess file which will lead to 500 error, if someone tries to access it over Internet.
  5. You will get to the login page: http://XX.XXX.XX.XX/afterlogic/, but you will be unable to configure it since there is another error: system not configured. So to fix it, please run the following command: chown -R www-data:www-data /var/www/html/afterlogic. This command will set the appropriate permissions.
  6. Now, you can configure the Afterlogic mail client and everything should work just fine.

The issue is resolved. Thank you.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.