All relevant MX records point to non-existent hosts. - [email protected]

Hi,
In my /var/log/exim4/mainlog I read the following:

** [email protected]: all relevant MX records point to non-existent hosts

This I don’t fully understand since I have the following MX records:

| MX Record | @ | mail.mydomain.com. 10 | Automatic |
&
| MX Record | @ | mail.host.mydomain.com. 10 | Automatic |

I also see a lot of frozen messages in the same log file.

If I read the content of the frozen message: sudo exim -Mvb 1nQ6ky-0000pE-CW:

[email protected]:~$ sudo exim -Mvb 1nQ6ky-0000pE-CW
1nQ6ky-0000pE-CW-D
--1646395800-eximdsn-753917903
Content-type: text/plain; charset=us-ascii

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

  [email protected]
    all relevant MX records point to non-existent hosts

--1646395800-eximdsn-753917903
Content-type: message/delivery-status

Reporting-MTA: dns; host.mydomain.com

Action: failed
Final-Recipient: rfc822;[email protected]
Status: 5.0.0

--1646395800-eximdsn-753917903
Content-type: message/rfc822

Return-path: <[email protected]>
Received: from root by host.mydomain.com with local (Exim 4.93)
	(envelope-from <[email protected]>)
	id 1nQ6ky-0000oY-8t
	for [email protected]; Fri, 04 Mar 2022 13:10:00 +0100
From: [email protected] (Cron Daemon)
To: [email protected]
Subject: Cron <[email protected]> sleep 60 && /usr/local/hestia/bin/v-add-sys-sftp-jail
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
X-Cron-Env: <SHELL=/bin/sh>
X-Cron-Env: <HOME=/root>
X-Cron-Env: <PATH=/usr/bin:/bin>
X-Cron-Env: <LOGNAME=root>
Message-Id: <[email protected]>
Date: Fri, 04 Mar 2022 13:10:00 +0100

Error: user syslog doesn't exist

--1646395800-eximdsn-753917903--

If you add hostname.domain.com as DNS server it will always create an mx domain. You can remove Host.mydomain.com for your mail server.

For [email protected] add host.mydomain.com as mail domain and create an account for root. You can forward it to your mail account if needed

Awesome, thanks a lot @eris!

I’m using Namecheap as DNS provider. I tried to create an account for root but it says that there is already a root account. Probably in Ubuntu 20.04 (I disabled that one for login security)? It’s certainly not within my HestiaCP install.

You need to create a mail account in HestiaCP for [email protected]

Thank you for your help. Sorry, I tried to add it as you said but I can’t seem to make it work. If I login I click on the user Admin (System Administrator). Now I see under ‘WEB’ my ‘host.mydomain.com’. If I than navigate to ‘DNS’ or ‘MAIL’ there is no option to add anything.

I did add ‘mydomain.com’ under a different user with no admin privileges. But I can’t add a maildomain or account within that same user for ‘host.mydomain.com’. Because than it says:

Error: Web domain host.mydomain.com exists

Please use the search function of the forum for:

Disable “Enforce subdomain ownership” for a moment.

1 Like

Thank you very much @eris. This took me in the right direction. I disabled ‘Enforce subdomain ownership’ and then noticed I also had to enable all options for the ‘System Administrator account’ within ‘Configure - Security - System Protection’.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.