Allow manual backups when backup system is disabled

Auto backups are disabled on our server currently, but I would like to manually create a backup file of a user into the current directory with v-backup-user - yet it refuses with Error: BACKUP_SYSTEM is not enabled.

Is there no flag to override this, or how about making the script aware of whether it is called automatically or manually somehow?

Delete the cronjob and it should work fine for manual backups

won’t it be recreated on upgrade?

No, not that I am aware of at least

Okay, found it in /var/spool/cron and disabled it.
Tried to run v-add-backup-host sftp with all parameters correctly (using ssh plain password login), but it silently fails with error code 1 :c

E_ARGS=1

So not enough arguments

It should work fine have used in the last few days multiple times …

But I supplied all arguments as instructed, including optional ones

And ssh connection also works with the credentials

Same error when using keys.
Maybe some config setting?

The actual issue was the sftp connection now being setup properly, I had assumed it works when ssh works. Maybe I can find a PR to improve that.

It requires SFTP connection… Otherwise it would be called SSH…

Other option is to do it over SCP but not all servers support SCP if they run in nologin shell…

my point was that the script should provide a proper error message rather than a silent failure, as in Towards proper error propagation - #3 by eris