Antivirus Option on Mail is missing?

How do we enable antivirus on mail accounts?

I have had Hestia running for more than 2 years. I just added a new domain to my server and it’s showing that antivirus is not active. If I edit the domain, I don’t see a checkbox to click that’s related to antivirus. Even on the other accounts that have antivirus active, there is no option on the edit screen.

I would assume the option should be there!?!? Is it missing from the GUI due to a recent update?

Screenshot 2022-04-26 at 22.24.25

That’s what I was thinking. I do not have that listed on my end. Here are screenshots of the options I have.

image

image

Why am I missing the options you have?

I’m running:

Probaly disabled clamav on installation or have less than 3gb memory?

1 Like

Thanks for the pointer. I will look into this. The server does have less than 3GB (currently 2GB with 2GB swap), so it may have been disabled. Any idea why the other domains would show the antivirus setting as being active?

If they were set before Clamav was disabled, would they still show as being active even though it’s disabled? I would expect them not to show, but given they are, that’s what has thrown me off and made me think ClamAV is active. I do think it was disabled. I will check, but it would be good to know why it’s showing active for the other mail accounts.

Thanks!

Is “Clamav” listed as an service. Some older versions allowed to enable antivirus when Clamav was not available

Thank you both for the pointers. @ScIT is correct, ClamAV is disabled. I configured this so many years ago, I just forgot. But it was because of the low memory on this server, and it causing too many issues.

So yes, looking at the list of services, ClamAv is not listed.

So any idea why the mail list is showing that antivirus is active. Is it checking some value in the Hestia DB that was left enabled before disabling ClamAV. I assume so. Any way to fix this (turn it off), so that it doesn’t confuse any future admin managing this server?

Thanks in advance for any advice you can provide.

Manually remove the antivirus flag in /usr/local/hestia/data/users/{user}/mail.conf

2 Likes

Thank you @eris! That did the trick. I was able to update “yes” to “no” in that file. So yeah, I guess because it wasn’t deactivated prior to disabling ClamAV, it wouldn’t have updated that file. I was thinking it was scanning something on the AV side to show that, but thanks for sharing the location of that file. Now it’s showing correctly in the Hestia GUI, which will prevent causing confusion to others that may log into it in the future (or myself, if I forget again. :wink: )

Thanks guys!!

2 Likes