Anyone on Upcloud? Problems with exim smtp timeout


I’m moving a client site to and it’s driving me crazy. It’s imposible to send mail.

Exim logs says
“SMTP timeout after initial connection: Connection timed out”

I have tried sending mail to 3 diferent address, and get the same error on exims logs.

I’ve setup the same intallation for my client over Linode and it’s working perfect.
Upcloud blocks 25 port but I’m using 587 port. I even made a php test with phpmailer setting that port.

Any ideas? Could it be something using 25 port even if I explicity tell to use 587? I even stopped exim daemon from listening to 25 port.


This is very strange, they lifted the ban on port 25 and all mails are going through.
Do exim need that port open even if it’s sending mail on another port?

Port 25 is still considered the standard for relaying between servers.

Submissions (Client to Server) can be done over 587

1 Like

Thanks a lot! I would check this info and see if I can set it to 587.

You’ll have to request them to open the port 25 over the chat, they’ll ask you 4-5 questions and then provide you a decision based on your reply and your website content. If they don’t approve it then you can try SendGrid’s free plan and relay message from exim to their servers.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.