Apache can not start after HESTIA fresh install - Debian 9

Hello HESTIA community.

I am facing an issue after installing HESTIA 1.0.5 (amd64) on a Hetzner cloud server with Debian 9.

The problem

After installation, apache2 can not start.

Running journalctl -xe I see that apche’s 8080 port is already in use:

(98)Address already in use: AH00072: make_sock: could not bind to address [PUBLIC IP HERE]:8080

Running netstat -nlp | grep 8080 I see that nginx is using that port:
tcp 0 0 [PUBLIC IP HERE]:8080 0.0.0.0:* LISTEN 958/nginx: master p

In HESTIA Web UI, I also see that the Web Template list for the default domain is empty. I haven’t added any other domains yet.

I re-imaged the VPS several times and the issue is reproducible 100% of the times. Below are all the steps (even before HESTIA install just in case)

Before HESTIA installation

I ran the commands as root

  1. Rebuild VPS from Hetzner Cloud Console
  2. Disable password authentication for ssh and restart ssh daemon
    sed -ri 's/#?PasswordAuthentication\s+.*/PasswordAuthentication no/' /etc/ssh/sshd_config && systemctl restart sshd
  3. Configure local timezone and locale
    ln -fs /usr/share/zoneinfo/Europe/Athens /etc/localtime && dpkg-reconfigure -f noninteractive tzdata
  4. Configure locale
    sed -i 's/# el_GR.UTF-8 UTF-8/el_GR.UTF-8 UTF-8/g' /etc/locale.gen && sed -i 's/# en_US.UTF-8 UTF-8/en_US.UTF-8 UTF-8/g' /etc/locale.gen && locale-gen && update-locale
  5. Download installer file
    wget https://raw.githubusercontent.com/hestiacp/hestiacp/master/install/hst-install.sh
  6. Run the installer
    bash hst-install.sh --nginx yes --apache yes --phpfpm no --multiphp yes --named yes --vsftpd yes --proftpd no --iptables yes --fail2ban yes --quota no --exim yes --dovecot yes --spamassassin no --clamav no --mysql yes --postgresql no --interactive yes --hostname [HOSTNAME HERE] --email [EMAIL HERE] --password [PASSWORD HERE] --port [PORT HERE] --api yes

During installation

WARNING: The following packages are already installed
exim4*

It is highly recommended that you remove them before proceeding.

To which a said Yes.

Then:

The following server components will be installed on your system:

  • NGINX Web / Proxy Server
  • Apache Web Server (as backend)
  • PHP-FPM Application Server
  • Multi-PHP Environment
  • Bind DNS Server
  • Exim Mail Server
  • Dovecot POP3/IMAP Server
  • MariaDB Database Server
  • Vsftpd FTP Server
  • Firewall (Iptables) + Fail2Ban Access Monitor

====================================================================

Would you like to continue with the installation? [Y/N]: y

Yes to continue.

The last message:

(!) IMPORTANT: You must logout or restart the server before continuing.

Do you want to logout now? [Y/N] y

Yes to logout and then reboot to reboot the server.

Issues during installation

Below I am quoting only the parts that seem to have issues.

() Configuring Apache Web Server…
hst-install-debian.sh: line 1204: /usr/local/hestia/bin/v-add-web-php: No such file or directory
hst-install-debian.sh: line 1204: /usr/local/hestia/bin/v-add-web-php: No such file or directory
hst-install-debian.sh: line 1204: /usr/local/hestia/bin/v-add-web-php: No such file or directory
hst-install-debian.sh: line 1204: /usr/local/hestia/bin/v-add-web-php: No such file or directory
hst-install-debian.sh: line 1204: /usr/local/hestia/bin/v-add-web-php: No such file or directory
(
) Configuring PHP-FPM…
hst-install-debian.sh: line 1210: /usr/local/hestia/bin/v-add-web-php: No such file or directory
(*) Configuring fail2ban access monitor…
cat: /usr/local/hestia/data/templates/web/apache2/php-fpm/default.tpl: No such file or directory
hst-install-debian.sh: line 1763: /usr/local/hestia/bin/v-change-sys-theme: No such file or directory

Installation log file here https://pastebin.com/wsgrTgkg

I think the problem might be related to –multiphp installation option. Any ideas what is going on and how to fix it?

Hi Felix

Thanks for your excellent and detailed issue post, this makes us much easier to help you (even if the solution is a fast one :slight_smile:) !

You need to use the installer from release branch, master is the current development and the v-add-web-php function isnt included yet to the deb package - this will follow with 1.1.0.

Download the installer like below and all should work as expected:
wget https://raw.githubusercontent.com/hestiacp/hestiacp/release/install/hst-install.sh

1 Like

Thank you very much @ScIT for the soultion! It worked as expected.
It was really negligence from my side, to use the master branch instead of the release. I didn’t even realize I was using the wrong branch :frowning:

A quick note… To solve the problem I used the following command to download HESTIA
wget https://raw.githubusercontent.com/hestiacp/hestiacp/release/install/hst-install.sh
(@ScIT I’m writing this because although your answer was spot on, your suggested wget command is still using the master branch)

Hi @Felix

Thanks for your answer, just edited my post :smile:.