Backup dir location

I see the hestia backup dir is in /backup as opossed to vesta in /home/backup
This creates a problem as my / is only 5gb in size! can i change the location of the backup dir?

thanks

Ok i tried deleting /backup and creating a sym link to parttion with plenty of space

ln -s /backup /files/backup

I can restore backups except for mail? I get error.

Error: invalid source path /backup/tmp.gDTMQWWbfZ/mail/tacklesale.co.uk/accounts.tar.gz
Error: Can’t unpack tacklesale.co.uk mail account container

any ideas?

See https://docs.hestiacp.com/release_notes/1.1.0.html

Breaking changes:

“/backup” folder cannot be a symlink anymore (security), use bind mount instead

mount --bind /backup /mnt/large-partition

Think this will solve the issue.

2 Likes

Does this work with lvm?

Yes, you can

Thanks i know how mount lvm volume, but as i understand with mount --bind i am not mounting lvm volume as it is already mounted?

cat /etc/fstab
proc /proc proc defaults 0 0

/dev/md/0

UUID=414dbaf4-f68b-4e32-a221-cc8f3d10d4bf none swap sw 0 0

/dev/md/1

UUID=1ef742a9-d317-41cc-a4f5-443a83b0851e /boot ext3 defaults 0 0

/dev/md/2 belongs to LVM volume group ‘vg0’

/dev/vg0/root / ext4 defaults 0 0
/dev/vg0/tmp /tmp ext4 defaults 0 0
/dev/vg0/var /var ext4 defaults 0 0
/dev/vg0/home /home xfs defaults 0 0
/dev/vg0/files /files xfs defaults 0 0

I want the /backup to be in /files/backup with /files being an already mounted lvm volumn, as i understand mount --bind allows a dir to be mounted on an already mounted partition which seem straight forward if not using lvm, i am just not sure how it works with lvm?

would i be looking at something like

mount --bind /backup /dev/vg0/files/backup

and if so would this remain in place after a reboot?

thanks

Why not just adjust your lvm settings and mount it as /dev/vg0/backup /backup?

I could, but i want /files to be not just for backups?

Would be much easier if we could actual just change backup dir as a variable?

thanks

Ok i tried

mount --bind /backup /files/backup

with these results

/dev/mapper/vg0-files on /files type xfs (rw,relatime,attr2,inode64,noquota)
/dev/mapper/vg0-root on /files/backup type ext4 (rw,relatime)

as you can see it have mounted, but /files/backup is using a different filesystem to /files ?

not sure if this will work?

that I also can’t say, probaly you will need to test it with running v-backup-users (or v-backup-user user).

unfortunately this has not cured the space issue!

/dev/mapper/vg0-root on /files/backup type ext4 (rw,relatime)

but when i copy large backup file to from /files to /backup (/files/backup) it fails with out of space error?

Though can confirm restoring users mail from backup works.

Back to the drawing board.

thanks

Ok, needed to restore this large backups mail, i had 45gb spare on my lvm group so created a volume for /backup FS xfs and mounted /backup on this, mail now restored.

Other this /backup dir issue which i think could be done better with an option to allow us to choose its location, well done on improving vestacp which i have been using for a few years.

cheers

1 Like

Lol, working my around the CP and looking server>config server I can see option to set backup dir path/dir :roll_eyes:

This just what i was asking for and makes things so much easier :slight_smile:

i don’t think that option works atm.

Using bind mount is as easy as using a symlink no need over-complicate it.

mount --bind /mnt/large-partition/optional-subfolder /backup

fstab:
/mnt/large-partition/optional-subfolder /backup none defaults,bind 0 0

1 Like

Have your tried mount --bind on lvm?

Not as straight forward from what i can see!

The option in server -> backup
It seems to be working in creates a symbolic link to the new folder…
lrwxrwxrwx 1 root root 5 May 4 23:24 test -> /test

mount --bind is pretty straight forward I’d say.
doesn’t matter if the underlying is lvm, md-raid or whatever unless you try to loop the lvm-mounted folder itself.

simply create a folder in the directory you mounted your lvm drive to, and bind mount that to /backup

or if you have space in /home anyway, mkdir /home/backup and bind mount that to /backup.

I am no fan of the issues with plain symlinks not working either. however, the loop should do just fine.

PS: just saw this…

mount --bind /backup /files/backup

this simply is the wrong order. mount what to where e.g. what device/folder (source, partition, free space) will be attached to which mount-point (destination, name, alias)

2 Likes