Can someone tell me why I cannot create a file in this place

Hello. Can someone tell me why I cannot create a file in this place? Every time I want to create a file, I cannot find any file I created.

Hi @stc2020,

Because default perms for dir /home/user/web/domain/ are 551 and that means your user don’t have write perms to that dir.

You can add write perms for your user using this (keep in mind that this will affect all your users and domains):

Note: replace YourUser and YourDomain by the actual data.

v-change-sys-config-value DOMAINDIR_WRITABLE yes
v-rebuild-web-domain YourUser YourDomain
2 Likes

Thank you for the quick response and your help. But how can I make it so that a file is created? I don’t know where I can modify it to work.

Doing what I said in my previous post.

1 Like

I mean, sir, where do I do this that you told me about? Is it in the hestiacp panel? Or do I do that via the Bitvise SSH Client? I do not have enough experience. I am a beginner in these matters. I mean, where do I do the explanation that you told me about? In any Makan. If you have any screenshot to help me with, I would be grateful to you from my heart.

Yes, you need to connect to your server via ssh. Those commands must be executed as root. Do you know how to connect to your server via ssh and login as root or a user with sudo privileges?

1 Like

Thank you, you are a person who loves to help everyone.
Well now that it’s clear to me I’m going to try that explanation. I hope I can do it.

1 Like

Thank you my friend, this solved the problem and now it works fine.

I have another problem, and it is because of this basic problem that made me take the previous actions. Perhaps I will find a solution to this problem from you.
Enviroment Required .env file available
I hope to find a solution to this.

You should ask the developer where to make that file usually it is the /home/user/web/website.com/public_html folder

hi.
This is what the developer told me.
Hello,
I solved the above problem on your hosting, but after that, other problems occur again. I suggest you use cPanel or for free control panel use, CloudPanel to install the application correctly.