Cannot Install on New Server wget script problem

Today i try to install HestiaCP on new vps server with OS Debian 12 64bit and encountere this error when try to download installation script:

--2024-06-21 05:17:45--
Resolving ( 2606:50c0:8000::154, 2606:50c0:8001::154, 2606:50c0:8002::154, ...
Connecting to (|2606:50c0:8000::154|:443... failed: Connection timed out.
Connecting to (|2606:50c0:8001::154|:443...

Whats wrong with it?

Hi @pakdhetimin,

Well, seems your system can’t connect to github using ipv6, I don’t know whether Github is the problem or it is your system but you can force wget to use ipv4.

wget -4

yes, its worked and script downloaded.

but, another problem, when i try to run the script (bash nothing happen…stuck no respon

Are you sure it downloaded the right file?


If you see this output:


# ======================================================== #
# Hestia Control Panel Installation Routine
# Automatic OS detection wrapper
# Currently Supported Operating Systems:

Try to execute bash in debug mode to view when the script gets stuck:

bash -x [here the options you are using]

here is the output, stuck in this state

That is because the ipv6 issue.

Try to tell your system to use ipv4 to resolve dns by default so edit file /etc/gai.conf and uncomment this line:

#precedence ::ffff:0:0/96 100

So it will look like this:

precedence ::ffff:0:0/96 100

Save the file and try to wget again the hst file and see if it uses by default ipv4:


If it downloads the install script,then you can use bash (without -x option)

1 Like

thanks, its worked and now its installing. i see the problem about ipv6 support

1 Like

no Github doesnt support Ipv6 globally

As it was an issue with connecting to


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.