Cannot login - authentication field is missing

After seeing email advising about new update 1.1.0, I tried to login and see if my HestiaCP has been updated automatically, only to find that I cannot login because the authentication field is missing.


So what should I do?

Auto Updater is currently not working due to the changed gpg key, so the system is not running 1.1.0 - so it should not be related to the new version.

Did you tried also to login in incognito mode or after a hard refresh (CTRL+F5)?

OK, good to know that auto update is not working.

How to login in incognito mode? I tried the hard refresh for my server using the CTRL+F5 or CTRL+SHIFT+R, both give me the same result, no authentication field is visible.

OK, I have found out what you mean by login in incognito mode and I accessed the login URL in a new private browser, but still I cannot see the authentication where I can enter the Google Authenticator code.

I can login via SSH with no problem. Now the question is, how to disable Authentication setting after SSH login.

I’ll check that here, for now, just run v-delete-user-2fa user then try to login again.

Yes, that worked!

So, to upgrade the system, I just run wget -qO - | sudo apt-key add - apt-get update apt-get upgrade without checking anything else?

This is a production server and so I do not want to make any mistake in upgrading. Any advice as to what I should do before upgrading is highly appreciated. Thanks! :pray:

First and foremost you need to have recent backups handy. If it’s a virtual server and the provider offers snapshots or images, make sure to take one before starting the upgrade. It’s also a good idea to perform the upgrade during the weekend, so if something goes wrong you have time to fix things up.

The rest is just as you said:
wget -qO - | sudo apt-key add -
apt-get update apt-get upgrade

I have already upgraded a production server (with just one user) and all went well.

OK, I did the following…
wget -qO - | sudo apt-key add -
apt-get update
apt-get upgrade

Reboot the server. Everything is fine.

But when I login and check the version of HestianCP, it is still 1.0.6

Something is missing. What is missing?

Try to run apt-get install --reinstall hestia and check if 1.1.0 will be installed.

Got this error after running that…

E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

Even though I got that error, now the HestiaCP version is listed as 1.1.0!

Looks like you didnt runned it as root, but glad it works now.

Yes, thank you!

However, the two-factor authentication login is the same as before. No extra field for code entry. Cannot login - I have to run run v-delete-user-2fa user to remove it in order to login. Now going back to the same problem I started with :frowning:

Is there update on this, i run in the same issues and had to delete the 2fa, would love to have this option

I do not have any solution yet. Still waiting for someone from the HestiaCP team to respond.

2FA is working properly, but to show the 2FA token field, you need to focus and “unfocus” (click on user name, then tab to password). Then the field get’s validated and it shows the 2FA token field. If you use saved passwords, the field doesnt show up automatically.

1 Like

Yes, indeed, it works by following what you said. Thank you so much!