Can't access backend

Hello.

So I ran apt update && apt upgrade, reboot my vps and now I cannot access my hestia install via 8083.

Not exactly sure what information i should be posting here, but I get a 500 error when I access the port.

Thanks in advanced. :slight_smile:

Probaly check /var/log/hestia/nginx/logs for the related line.

Hmmm

Says no such file or directory found.

/var/log/hestia/nginx-error.log

1 Like

Permission denied as root user

Sorry, was on mobile. You should be able to access the log from root user without any issues. Maybe check the output of systemctl status hestia?

● hestia.service - LSB: starts the hestia control panel
Loaded: loaded (/etc/init.d/hestia; generated)
Active: failed (Result: exit-code) since Sat 2021-07-03 22:52:36 HST; 9h ago
Docs: man:systemd-sysv-generator(8)
Process: 1140 ExecStart=/etc/init.d/hestia start (code=exited, status=127)
Tasks: 2 (limit: 1077)
CGroup: /system.slice/hestia.service
├─1443 nginx: master process /usr/local/hestia/nginx/sbin/hestia-ngin └─1445 nginx: worker process

Had to truncate due to links being posted

Hi, so I haven’t seen much of a solution here.

Can someone please help me? I appreciate anything you have for me but I’m actually a noob at all of this.

Also don’t mean for it to seem like I’m in a rush but I do have some things I would rather not redo because I have to wipe the server and start over.

Thank you for your time

Number one rule “Never upgrade/update before you backup” I think there’s a log for the upgrade process somewhere.

What OS are you using ?

Ubuntu 18.04 iirc I’ll have to look later to be sure.

sudo apt-get install libicu60

1 Like

This worked. I didn’t know if it was going to since it kept throwing internal server errors, so I rebooted after installing and it took a minute and then showed up my login page.

Thank you so much. I highly appreciate your support.

1 Like

Same problem happened to me. Fix worked. Thanks!

Can we prevent this from happening again?

1 Like

See [BUG] Can not change mail account password after upgrade · Issue #1962 · hestiacp/hestiacp · GitHub

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.