Can't connect to API from specific IP

Ok this is going to be a long one. So when I try to connect to the API through curl I get a connection refused error.

So I do the normal troucbleshooting and try to connect from a different IP. It works flawlessly. I check the nginx access logs and there is nothing in there about any connections to the API.

So I try connecting to the with no port number. Works great and it perplexes me. I have checked the firewall the IP is NOT banned, I have added the IP to the ignore list. I try again same result. Remember I can connect no problem from a different IP.

Next step I stop the firewall and fail2ban. Try connecting again and still get connection refused.

I try adding the IP to the firewall and no change.

Every log I have checked says nothing about connections to the API and I am at a loss here.

Anyone have any ideas why an IP will connect without the port number but, when the port is added the connection gets refused?

Again the IP is in the ignore list, is not banned and can connect without the port number.

Edit: Behavior is the same if I try to connect to IP:8083/api as well.

Check /var/log/hestia/auth.log and /var/log/hestia/nginx-access.log

For the curl calls…

You can also try:

allow-all in the white list for ips

Checked both and they do not even show the IP is trying to connect. I have tried allowed-all, and same results.

Even checked /var/log/hestia/nginx-error.log to no avail this one had me really stumped.

How do you connect?

admin:password or api keys?

Try access log to see what hits there are ?

If you connect with curl at least an call should be visible

API Keys

See that is the funny thing If I try to connect without the port number it works and shows in the access.log. If I add the port number I get a connection refused.

I have tried the same commands from my home computer and it works fine even with the port number. It shows in the access.log as well. This behavior is the same for any IP except for that one IP.

I have asked for someone at the host to look into my account and see if their may be a missconfig in it but, thought I would post here and see if anyone else had seen this behavior.

OK so apparently someone has blocked the non standard ports in my provider’s router. Don’t ask me why and I would NEVER have thought of this myself. Makes no sense to me but that is what they said. I will let you know if this fixes it after they do their thing.

Yeah that seems to have been the issue. Funny it was fine until 3 days ago.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.