Can't create a database via the CLI

[email protected]:~# v-add-database traffic test43 kkfdsj43ifdsj2I
Error: mysql host EMPTY_DB_HOST doesn’t exist
Through the web control panel the base is created, but cli command doesn`t work

Do you have mysql installed?

If not use v-add-database traffic test43 kkfdsj43ifdsj2I pgsql

1 Like

Of course Mysql is installed, I use mysql for Wordpress blogs

Hestia is 1.5.2
Debian 10.

I tried to create a base with the command “v-add-database traffic test43 kkfdsj43ifdsj2I pgsql” In response, a similar error

You have just tried to add a posgres database

1 Like

Yes, I understand that. But I have no idea why it doesn’t work through the CLI

looks like a bug, try v-add-database user dbname dbuser dbpass mysql localhost

the host seems to be mandatory.

1 Like

Wow!! That solved the problem, thank you, you’re the best! I wish you prosperity. Hestia is the best product for server and site management. I enjoy every day when working with the panel.

v-add-database jaap database user password

Seems to work fine on my server for some reason…
get_next_dbhost should select the next host don’t know why it doesn’t work…

1 Like

Maybe his system is defaulting to a different host and therefore it won’t work if you do not specify the correct host

It used to work for me too, but I don’t know what action made it stop.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.