Can't Install HestiaCP

Hello, I have been using Hestia for a long time, and after installing it a couple of times today, I came up with an error.

(y: command not found)

I can’t get past that screen. I did apt update and an apt upgrade. I also rebooted and still can’t get it working.

currently on a droplet on DigitalOcean I also have another website with HestiaCP on Droplet, but since the new update, I cannot install it.

Hi @tuton,

That’s really strange. This is the code asking for confirmation:

# Asking for confirmation to proceed
if [ "$interactive" = 'yes' ]; then
	read -p 'Would you like to continue with the installation? [Y/N]: ' answer
	if [ "$answer" != 'y' ] && [ "$answer" != 'Y' ]; then
		echo 'Goodbye'
		exit 1

It accepts y or Y as answer and doesn’t try to execute the answer so I’m wondering why you received that command not found error message.

What is your OS? What are the options you used to install (the entire command you are using)?

If you are adding all options like user, password, email, etc. to install command, you could try to add --interactive no to install command to avoid the questions but I’m really curious about your issue.

Hello @sahsanu Sorry for not providing the rest of the information.
I am currently on Ubuntu 22.04 (LTS) x64 fresh install only ran apt update and apt upgrade this is the way I always done on my previous droplets

command I am running is the following:

bash --port 2083 --hostname --email [email protected] --password random password --clamav no --force

I also ran the with the following command

bash --port 2083 --hostname --email [email protected] --password my password --clamav no --interactive no --force

still same error

I can’t reproduce the problem.

And using --interactive no is asking for confirmation to continue the install?

Could you please enclose email and password with single quotes and try again?

bash --port 2083 --hostname --email '[email protected]' --password 'random password' --clamav no --force

I try running only


and it works fine

running this give me the same error

bash --port 2083 --hostname --email '[email protected]' --password 'random password' --clamav no --force

Did you copy/paste the command? If yes, try to write it manually, without copying it.

Are you using any special character in your password?

Also, show the result of:

echo test@test

1 Like

Awesome writing it down work it seems when copy paste it was not working but I type everything and boom all works.

Thanks you!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.