Can't parse sftp backup configuration error after Hestia 1.5.0 update

After automatic HestiaCP 1.5.0 update my remote backups are not running.
I am getting this error:

Can’t parse sftp backup configuration

I have tried to save again SFTP remote backup data in Hestia panel and it said it has been successfully saved, but the same error continues there when trying to execute any v-backup-user command.

Any tip?
Thanks in advance for your help!
PD: BTW, my ip/phpmyadmin is gone too after this update, it only works for accounts but not inside hestia cpanel. It shows 404 error.

As far as I know, we havent changed anything to the backup function. We’ll do a check here if we can reproduce the issue.

Check the changelog:

  • NOTE: Changes have been made on how phpmyadmin/phppgadmin config are included in apache2 config. To restore to the old behaviour add IncludeOptional conf.d/*.inc below IncludeOptional conf.d/*.conf in /etc/apache2/apache2.conf and restart your server.

We do NOT suggest to restore the behaviour, due to potential security issues.

About backup, I forgot to say that my system is Debian 11 (just in case this helps).

We adjusted how read the config file how ever it should not affect it

Can you dm me the sftp.backup.conf in /usr/local/hestia/conf/

I have found and fixed the problem, thanks to eris.
I was using a # character in the password value and it seems not allowed anymore in this new update, so I have changed the sftp password and now it runs well again.

Thanks for your help!


Let me check if we can allow it again the next release …

Should be fixed in next release

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.