Can't send email out - but receive


Recently i installed HestiaCP on my server, and everything is working well. (You have a fine product here).
The only thing i have difficult with, is the mail server - which can receive email from everywhere, but can send only internal mails. if i try to send it outside, it’s not reach. in logs i can see connection time out, and later i receive mail:
A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:…

Tried to check DNS records, and it’s seems to be ok.
Telnet to google in port 25 failed, but does succeed in 465 or 587.
I’ve managed to connect outlook to my mailbox - and again - i can send to myself, receive from everywhere, but can’t send outside.

Check in this forum and other places, and i must ask this question:
Do i must configure rely SMTP server if i want to send email out’ or it can be done all by my own server?

Probaly your provider has blocked port 25. Has been handled a lot of times here in the forum, have a lock in the search function.


Since i tried to avoid opening ports, in configuration file i specifically put there to go via 587. it’s not help?

Only method to resolve the issue is to use an smtp relay service like Amazon SES / SMTP2GO

Ask your hosting provider to open port 25

Just thought I would charm in here:

There is a port checking tool
just input the ip of your server and let it do its thing, there are other ones out there but I use this one.

The problem is from inside to outside, your tool checks from outside to inside :).

Well, after a bit of headache, the provider had opened port 25 and now mails ar going through.
Why configuration for port 587 doesn’t work?

Communication between sending servers goes still over port 25…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.