Can't send emails

Can I use 465 or 587 as default port.

Also when I try to add the email in Outlook it says IMAP a secure connection to the server cannot be established. And when I checked https://imap.mydomain.com I got certificate warning however both web and mail got green check for SSL.

Use mail.domain.com instead…

If you want to use 465 or 587 use a smtp relay service instead. AWS Sendmail or https://www.smtp2go.com are cheap and/or free

I’m using mail.mydomain.com as IMAP and SMTP but when I choose SSL/TLS for incoming server (IMAP) I got the above error and the only way to pass it is to choose “None”, but in any case I’m still not able to send emails!

What port are you using?

When your ISP is blocking outgoing emails on port 25, you can send emails to your hestia server, but your hestia server can’t relay your message to for example gmail → timeout…

I use Outlook IMAP/SMTP 143/587 and email stuck in queue in Hestia Server

cat /var/log/dovecot.log
Dec 13 20:02:26 imap-login: Info: Login: user=<[email protected]>, method=PLAIN, rip=102.40.167.244, lip=192.168.1.2, mpid=16532, session=<FiM+jQzTl52mKsKf0>
Dec 13 20:02:59 imap([email protected])<16532><FiM+jQzTl52mKsKf0>: Info: Logged out in=106 out=1369 deleted=0 expunged=0 trashed=0 hdr_count=0 hdr_bytes=0 body_count=0 body_bytes=0


[email protected]:/var/log/exim4# cat mainlog                                            
2021-12-13 20:01:52 exim 4.93 daemon started: pid=16472, -q30m, listening for SMTP on port 25 (IPv4) port 587 (IPv4) and for SMTPS on port 465 (IPv4)
2021-12-13 20:01:52 Start queue run: pid=16473
2021-12-13 20:01:52 End queue run: pid=16473
2021-12-13 20:02:26 1mtFk-0204Ib-Rm <= [email protected] H=(Astra) [102.40.167.244] P=esmtpsa X=TLS1.0:RSA__AES_128_CBC__SHA1:128 CV=no SNI="mail.mydomain.com" A=dovecot_login:[email protected] S=2646 [email protected]
2021-12-13 20:04:36 1mtFk-0204Ib-Rm H=hotmail-com.olc.protection.outlook.com [104.47.58.161]: SMTP timeout after initial connection: Connection timed out

As written, your vps provider is blocking outgoing port 25, ask them to unblock it.

1 Like

Ok, thank you for support

@ScIT

Do you know why I’m getting a certificate warning for outgoing emails when I try to add my email in Outlook IMAP/SMTP 143/587 TLS, also for IMAP when I choose TLS it didn’t connect, it has to be NONE although Let’s encrypt is applied for mail and webmail?

Looks like a local issue: The r3 lets encrypt cert got loaded properly. Check the cert chain under certification path.

The root cert there should be trusted, is your os up to date?

Windows 7 :roll_eyes:

Well, then clearly no. Update your OS to Win10/11, this is not related to hestia at all…

Ok, what about IMAP issue? is it the same

I’m not going to provide support for any os that is already out of support since years… And well, if its the same system and same cert, it will not work aswell…

Not related to Hestia

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.