Certificate authority error

Hey, I’m just trying to add a custom Cloudflare SSL for my domain, and Cloudflare only provides an SSL certificate and a private key. So, I have added both, but hestiacp doesn’t allow me to add SSL without adding “certificate authority”. The problem is that it clearly states that this is an optional field, but it still throws this error. Can anyone on the team assist?

Edited:

Latest hestiacp 1.6.0
OS: Ubuntu 22.04 LTS
Server: Nginx

https://developers.cloudflare.com/ssl/origin-configuration/origin-ca/

Thanks for the reply. But this is not the solution. This post is for creating CA certificates. I have mentioned that I already have a certificate and a private key ready, but the problem is what I need to enter in the certificate authority/intermediate box. You know that Cloudflare does not provide a certificate authority or intermediate. I hope you understand. Please see the image below. If I leave this, it throws an error, even though it is an optional box.

Check point 4 and use that root cert.

1 Like

Yes, thanks, it worked. Previously, I had tried with the same step, but it didn’t work. Now I know why: in hestiacp, you must download the RSA certificate, not the ECC. Have a great day.