Change default IP for nginx webmail config

For some reason when I create a mail domain, it uses the local IP of my server, not the public IP in the nginx.conf (in the listen directive).

I need it to use the public IP.

If I manually edit the webmail nginx .conf then it works, but of course this is not proper solution as it will get overwritten again later.

When adding web domains, they also default to the private IP but I’m able to select the public IP instead during creation. However no such option exists for mail domains.

If it’s relevant, I use the private IP to access the panel (only I use it)


In /usr/local/hestia/data/users{user}/mail.conf you can set an ip address.

Probally changing works fine

Thanks, but there’s no IP listed in that file.

I suspect I have made my global default IP the local one instead of the public one, is there somewhere to change that?


Adding doesn’t work either

If you add to the server with the correct ip address it should work fine

Other option is in:
edit/ip/ and assign the private ip address to the admin user only and use a second user for mail domain

Ah yes thank you, the domain I was testing this with didn’t have a web site configured. If I create a web domain on the correct IP, the mail domain copies it. :+1:

Ah thank you, after digging around I found the IP configuration by clicking Server (cog in top right) / Configure / Network. I set the private IP as not-shared and assigned it to admin user. My other users now don’t see this as an option when creating a web domain.

Thanks for the help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.