Change default PHPMyAdmin URL

Hi,

We noticed there’s a field called “phpMyAdmin URL” in “configure server” page, under section “Databases”. Is this a field to change URL to access PHPMyAdmin?

We tried to put inside some values: /directory, full url, etc… but nothing worked.

Is that possible here?

Regards

You just need to enter a alias, like pma or phpmyadmin.

I tried pma in mine, but it just broke this button:

removing it made the button work again

But the pma is accessible over /pma, right?

The backend issue with wrong link is a known issue (because it’s the same as for webmail): https://github.com/hestiacp/hestiacp/issues/659

Hi,

I have just set ‘pma’ and ‘/pma’ (without quotes) and it’s not working.
It’s an Ubuntu 18.04 whit a new fresh installed HestiaCP.
Even restarted Apache and Nginx, but it does not work.

Should it replace /phpmyadmin acces or just create an alias?

Regards

It triggers the script v-change-sys-pma with the alias as argument, it replaces the alias name in nginx/apache2 configuration.

Hi
I checked the Hestia log and it’s noticed:

2020-01-31 12:01:18 v-change-sys-config-value ‘DB_PMA_URL’ ‘pma’

But this script only changes $HESTIA/conf/hestia.conf var.

I think it does not go any further. Am I wrong?

Regards

Hi @ScIT

I just ran the script you say in terminal.
URL is replaced ok.
I think there’s a problem in the GUI as it does not call this script and so URL is not changed.
Could you check please?
Regards

1 Like

Hi @ScIT and @mredig

And there’s also the bug @mredig says. In fact, URL on this button keeps the port 8083 and this should be port 80.
The URL is
https://DOMAIN:8083/NEW_ALIAS
and should be
https://DOMAIN/NEW_ALIAS

Regards

We’ll check that of course.

1 Like

Hi,

I also have seen that mail with credentials, after creating a database, has a wrnog URL after modifying it.

Regards

I have the same problem.
When adding a new name, do not sign in.

Please open a new thread and put all relevant informations there.

1 Like

When I installed Hestia, I saw same error, but it works like vesta, you need to change the link into apache config (if you have apache installed). Absolute path in linux is /etc/phpmyadmin/apache.conf. Inside you change route alias by same value that you put into hestia basic configuration interface.

After you change this file, restart apache service

I use Cloudflare on my domain.

I am using Debian version 10.3 (x86_64) with HestiaCP v1.1.1

I noticed that the link to open phpmyadmin, as shown below, shows a 404 error when opening

With admin user, in managing server, I have a screen where we can change the access link to phpmyadmin making it more secure.
image

An entry was created in cloudflare for pma pointing to the server’s ip and I still can’t access pma.meu-domain.com

the phpmyadminurl setting does not change it to a subdomain, but only changes the alias. so your-domain.com/phpmyadmin becomes your-domain.com/pma

if you want to have a sub-domain for it, you can adjust or create the nginx/apache config-files for phpmyadmin manually and add a vhost there.

I am going to merge this into the thread, as it’s already discussed there, please only open new topics if there are no ongoing discussions or if it’s really a different question.

Thanks for the answer @falzo

Even trying to access my-domain / pma go to page 404

See https://github.com/hestiacp/hestiacp/issues/790

This behaviour has been confirmed as a bug… There is somebody who will take a look at it…

1 Like