Changed hostname, now cannot access webmail or phpmyadmin

I’ve done a new install of HestiaCP on a new install of Ubuntu 18.0.4 LTS and all was ok until I tried mail-tester.com, which complained my hostname didn’t match so I used v-change-sys-hostname to mail.domain.tld.

However, after doing that going to mail.domain.tld/webmail or mail.domain.tld/phpmyadmin no longer works. Also tried domain.tld/webmail and the original hostname, but only get page not found.

I suspect this is a rookie error, because this is my first install of HestiaCP. Any guesses as to how I’ve screwed this up or what I’ve missed?

Ancillary question: Once you have more than one website on a server, so potentially many domains, how do you handle the HELO mail sending the right domain (or does it always use the hostname regardless of the email domain sending from?)

Does new.hostname.com exists under the admin account?

Webmail is by default only availble under https://webmail.domain.com

Well that solves it. The link from HestiaCP was taking me to /webmail, but webmail.domain.com does indeed work.

Thanks,

Pete

Can you give me a location where the link was visible. Will change it for further release…

My mistake, the /webmail link was from a Google search while I was trying to figure out why the link in HestiaCP wasn’t working. The HestiaCP link (first icon in the mail list) takes you to [email protected]