CloudFlare Glue record


I want to create NS records for my domain name to be used by my other domains, my primary domain is hosted at CloudFlare and I have tried to create NS and A record but it didn’t go through when I went to Godaddy to change the NS “We can’t save your changes because this nameserver isn’t registered. Verify your entry for accuracy and check with your DNS provider that this nameserver is registered.”

CloudFlare DNS records:

ns1.hcp        A 
ns2.hcp        A 
ns1            NS
ns2            NS

What I want is to keep my primary domain managed by CloudFlare, the rest of my domains to be managed by Hestia DNS.

Hello @Chesley,

This is totally off topic and not related to Hestia but…

To be clear, you want to add and so they are the NS servers for or you want to use those dns records only for otherdomains.tld?

I’m asking because if you want to use and only for your other domains, you don’t need to add any glue record in your registrar.

Why you add ns1 and ns2 NS records? You don’t need them. If you post your real domain we could check it without trying to guess what is going on :wink:


1 Like

Hi @sahsanu

I want to use and for otherdomains.tld.

I already had these two records created yesterday but GoDaddy didn’t accept them for otherdomains.tld, that’s why I tried to created NS records

ns1.hcp A
ns2.hcp A

If you can resolve and

dig +trace
dig +trace

then you should ask GoDaddy the real reason they can’t add those domains as ns for your other domains.

They are pointing to my server, will check with GoDaddy. Thanks @sahsanu

1 Like

What is your top level domain? Just curious because some country code top level domains have some requisites for nameservers:

.com domain

I checked with GoDaddy, here’s their reply:

This nameserver are not assigned for the domain, so you need to assign the nameservers in hosting server or generate a new nameservers in hosting server.

You need to contact your hosting provider and tell them to assign the nameservers for this domain otherdomains.tld or generate a new nameservers.

If I understand their reply, they want that the name servers for otherdomain.tld be already active so you need to create in Hestia the dns zone for otherdomain.tld and add the NS records pointing to and

I have this domain already in hestia, and these NS records already created by default. Not sure what else can be done

It should be great to know your domains to be able to check your ns conf.

Check if your server is really serving the right ns records:

dig otherdomain.tld ns
dig otherdomain.tld ns

root@panel:~# dig otherdomain.tld ns

; <<>> DiG 9.16.1-Ubuntu <<>> otherdomain.tld ns
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 51188
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1
;; WARNING: recursion requested but not available

; EDNS: version: 0, flags:; udp: 4096
; COOKIE: 5a898d6f53c6a55901000000653127e9b4c14095c5031387 (good)
;otherdomain.tld. INS

;; Query time: 8 msec
;; WHEN: Thu Oct 19 15:58:17 EEST 2023
;; MSG SIZE rcvd: 71

You bind server is failing to serve the zone otherdomain.tld

I am able to dig ns

And I’m also able to dig @ otherdomain.tld ns

But still not able to
dig otherdomain.tld ns


Yes, because your bind server is also a recursive resolver.

If you didn’t change your name servers for otherdomain.tld then you should see the answer from the current dns server for your domain.

Because seems there is some problem with your dns domain conf.

Please, tell us what are your domains, it is really hard to guide you without this info, if you don’t want to make them public, send me a private message here in the forum and if you are not able to do that, tell me it here and I’ll open a private message to you.

By the way, show the output of (replace user and otherdomain.tld by the real ones):

v-list-dns-records user otherdomain.tld

1 Like

Just for the records.

I’ve been talking to @Chesley and we have fixed the SERVFAIL issue. The zone was not loading due a duplicated record (TXT and CNAME) which is not allowed.

Oct 20 01:57:10 hcp named[427021]: dns_master_load: /home/example/conf/dns/example.tld.db:24: _dmarc.example.tld: CNAME and other data
Oct 20 01:57:10 hcp named[427021]: zone example.tld/IN: loading from master file /home/example/conf/dns/example.tld.db failed: CNAME and other data
Oct 20 01:57:10 hcp named[427021]: zone example.tld/IN: not loaded due to errors.

Regarding the issue of adding the name servers in GoDaddy it is not resolved yet, he needs to talk to GoDaddy’s support.

I guess you should do all in cloudflare. And agree, totally out of topic.