Configuring exim4 for Discourse

Hello everyone!

So far, I managed the following:

  • Got my website to work in Hestia with SSL
  • Got my emails to work in Hestia with proper TLS certificate from Let’s Encrypt
  • Successfully installed Discourse with nginx as a reverse proxy

Now I am configuring Discourse and I noticed that it fails in sending emails. I get 451 Temporary Local Problem.

May I ask you, without going through this headache myself, how did you get Discourse to work with Hestia mail? Which configuration did you use?

Thank you in advance!

Hi delta

Thanks for your request, settings are quiet easy, we use the hostname for the smtp communication, a small sample out of our config:

  DISCOURSE_SMTP_ADDRESS: server.domain.tld
  DISCOURSE_SMTP_USER_NAME: [email protected]
  DISCOURSE_SMTP_PASSWORD: YourPasswordOnlyCharsAndNumbers
  #DISCOURSE_SMTP_ENABLE_START_TLS: true           # (optional, default true)

Then rebuild the container and you should be fine.


Hello ScIT,

Turns out you can’t use an email different from the discourse domain. In my case, I was trying to use [email protected] instead of [email protected].

Thank you for your response! Hope this will help some more people.

Also, Hestia is wonderful, keep up the good work!

1 Like

Glad you found the solution, thanks also for reporting it back!