Connection to IMAP server

I’ve just added SSL to one of my email accounts in the panel using Lets Encrypt, now when I log in to webmail I get the error:

Connection to IMAP server failed.
Server Error: AUTHENTICATE PLAIN: Authentication failed

Before adding the certificate everything was working fine. I’ve tried rebuilding the domain and that has not worked.

Any ideas?

Now after about 5 minutes it logs out and it says:


Requested compose session not found.

I would probaly start checking the (dovecot) log files, verify if the service is up and running, if connection works unencrypted and so on :slight_smile:. Authentication failed leads to a wrong password, would be also an idea to create a new mailbox just for testing, if all works, probaly reset the mailbox password.

A lot there to debug and test.

I removed it, then added a different one and it works.
Thanks for the reply and help.

did you able using email client?


as email clients I have tested thunderbird, outlook express, outlook 201x, mobile k9 mail, native android and IOS clients, php clients(wp,presta,opencart,laravel) and all are working properly

1 Like

I’d like to add to @Lupu 's list, Opera Mail which is working fine too :slightly_smiling_face:

Yes, no problem sending and receiving mail.
Only had a problem with the above error when adding SSL to one of the email accounts.
I deleted the email and recreated and it worked. Should of tried that first before posting.

All good, thanks.

why i am always failed, i tried many times stil failed.
fresh install also failed

kind to share the detail please

My setup is just default, nothing custom. Do you have problems connecting to dovecot/imap port or user authentication?

i do exactly as default but still got failed :sob:

i am using cloudflare for managing dns

Make sure Cloudflare is disabled for mail subdomain (Or smtp / imap / what you want to use)

Now testing

Finally its done, Thanks all

i give inform later on the details

ok, here are some detail maybe not all but let me explain a bit

I am buying domain on (hope is okay in here i mention), and i use the free :grin::sunglasses: cloudflare for manage dns
I use several vps provider for hestia it self
I set my domain into cloudflare dns such as :grin:
wait a bit perhaps 2 or 3 mins then will resolve
and set the A record

after finish installing hestia, i am starting adding user and adding domain
when adding domain now i also activate the Create DNS zone also Enable mail for this domain
when it finish created, i think i have read on this forum too or on discourse discussion that somebody inform to rewrite all the dns into cloudflare
after i copy all the dns that have been created by hestia into cloudflare. I do make sure that ssl is active too.
If i am not wrong there are 16 record
then i check the ssl on the mail and make it activate, just wait several seconds

then start adding your first email account
dont forget to copy all the details, i am afraid that your forget your password after reading long boring this story
for me before I adding into thunderbird or spark mail even other mail client cause i have bad experience failing many times
i am testing each A record, which is the best that I put for the mail server on the mail client :grin:forgive me, once again i am still learning and hestia rocks!!!
and now you already find out the best that you want to put on the mail server field
lets add your mail account into mail client that you love and starting email to your love one using the new email that you’ve been setup :wink:

and now the problem, hehehe…
why my email always on spam :sob:

i not sure this is the rite solution,
so i sign up into several smtp relay, then i decide with mailjet.
i setup the exim smtp using smtp relay of mailjet
now my email not into spam and even can sending into outlook / hotmail too
ups, dont forget to set the dkim, spf, dmarc or anything else that need for smtp relay provider

i think is all, maybe tehre a few things that i do forgeting
fell free to inform me

thanks all hope can help setup the mail using cloudflare and mail client :v::beers:
after one day, i tried setup on several vps and this is the result

Today even more strange

i setup hestia on alibaba cloud based the email working nicely
i setup another vps on racknerd using hestia too

same setup, but when i am sending mail from alibaba cloud seamlessly working terrific then i try using vps from racknerd
i got this

Any idea guys?

did suppose to be the same as my vps on alibabacloud isn’t?

if I turning off the STARTTLS, the email is working fine
but it suppose work rite?

thanks all