Custom Nameservers In Hestia

I have just installed the Hestia control panel on a Oracle Cloud server, and I am not able to make my custom name servers to work

I have done the following:

  1. The nameservers were created more than 24 hours ago at goddady and they look like

host - ip-address
ns1 - my server ip address
ns2 - my server ip address

  1. I have created a user account at hestia cp and on that user I created a website with my domain that includes a dns zone with all default records

NS record ns1 pointing to ns1 mydomain
NS record ns2 pointing to ns2 mydomain
A record for ns1.mydomain pointing to my server ip
A record for ns2.mydomain pointing to my server ip

what happens is that the nameservers are not responding, even if I try to ping them directly in the server

is there any step that I missed to create the custom nameservers at Hestia CP?

thank you

Have you opened ports on youre router like port 51 i think it is for dns?

If self hosting go into firewall in the panel and it shows all the ports that need forwarding

Try this awesome document.

hi, yes, you said por 51 and them dns, but dns port is 53, I do have port 53 open, port 51 is closed, do I really need port 51?

DNS is port 53 TCP and UDP

Yeah yhats why i said i think because i am not near my computer to check

yes, DNS is working fine on port 53

if I add this line “nameserver” to /etc/resolv.conf , them I will be able to ping my domain and the nameservers inside the server via ssh, but if I remove it stops pinging
this probably means that the dns is working fine and that the problem should be outside of my server right?

This is pretty much what you need to setup for your site to show up!

hestia ns

I have my site on CF dns and have kimsufi dedicated IP at the bottom showing!

The rest of setting is for ftp and webmail and stuff setting on the bottom of these lines!

Good luck m8 :wink:

PS. I might be late for sharing this and may had it figured out by this time

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.