Custom Template for Docker App

Hello guys,

I searched the forum, found some topics, but not the final solution.
Like other users I want to open a docker app via subdomain and not via port

App: Uptime Kuma
Port: 3001
Access via IP 123.456.789.1:3001 is working
Access via is working

Objective is access via

I created two new templates in /usr/local/hestia/data/templates/web/nginx/

  • uptimekuma.tpl
  • uptimekuma.stpl

I have assigned the template as “Proxy Template” in the domain settings for

In uptimekuma.tpl I set:
location / { proxy_pass http://%ip%:3001;

In uptimekuma.stpl I set
location / { proxy_pass https//%ip%:3001;

I also executed the command v-rebuild-user myuser yes

On opening I get Error 500 (Internal Server Error)

(Oracle Cloud Server with Ubuntu 22.04.2)

I hope you can help me to solve this problem. Thank you :slight_smile:


How ever I only have have them for nginx only setups
If you use nginx + apache2
Replace: web_port with proxy_port and
web_ssl_port with proxy_ssl_port if I am right

And add this to nginx .conf

Also I run it on port 3000 instead of 3001…

Thank you @eris

I downloaded the templates to /usr/local/hestia/data/templates/web/nginx/php-fpm/ and extended the file /etc/nginx/nginx.conf

My next challenge is to assign the uptime-kuma template to my domain

Currently I don’t see it in advanced options:
Web Template (Apache2)
Backend Template (PHP-FPM)
Proxy Template

In the docu I found things like user.ini or php-fpm pool config but as a linux server newbee I have a lot of question marks in my head what to do.

I installed Hestia with --interactive no parameter. So I think and when I look to the settings, apache2, nginx and php-fpm are running.

Thanks for your time to assist me :slight_smile:

If you use Nginx + Apache2 you should put them in /usr/local/hestia/data/templates/web/nginx/ and make the changes I explained :slight_smile:

Woohoo - Thank you very much! Learned something again.
It is fun to experiment with Linux servers :wink:
Have a nice evening.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.